Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
  1. #11
    ROG Enthusiast Array
    Join Date
    Jul 2018
    Reputation
    20
    Posts
    52

    Mokichu just posted updated audio drivers (UAD and HDA), the thread has also been copied back to our X370/X470 thread. I shall try them and let you know whhat i find.

  2. #12
    ROG Enthusiast Array liakou PC Specs
    liakou PC Specs
    MotherboardCrosshair VII Hero X470
    ProcessorRyzen 3900x
    Memory (part number)G.Skill TridentZ Neo 32GB 3600C16
    Graphics Card #1ASUS ROG Strix Vega 64
    MonitorSamsung Odyssey G7 32
    Storage #1Samsung 960 Evo 250GB
    Storage #2Samsung 860 Evo 1TB+500GB
    CPU CoolerArctic Liquid Freezer II 360
    CaseCoolermaster H500M
    Power SupplyCorsair RMi 850
    Keyboard Logitech G915
    Mouse Logitech G PRO Wireless
    Headset Corsair VOID Pro
    Mouse Pad Logitech Powerplay
    Headset/Speakers Logitech G560
    OS Windows 10 Pro x64
    Network RouterZTE ZXHN H168N VDSL2 + ASUS RT-AC86U
    liakou's Avatar
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    73

    Thanks, hope you find a positive change!

  3. #13
    ROG Enthusiast Array
    Join Date
    Jul 2018
    Reputation
    20
    Posts
    52

    Update for sonic suite release in windows store, will post if I find some changes

  4. #14
    ROG Enthusiast Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    34

    Forgive the stupid question: Can I use Sonic Suite if I'm running a dedicated sound card (The Creative Sound blaster AE-5 to be specific) or does this software only work with Supreme FX? I don't suppose there's a way I could jerry rig a solution, let Sonic Suite and Supreme FX run while I listen to audio through my AE-5?

  5. #15
    ROG Enthusiast Array
    Join Date
    Jul 2018
    Reputation
    20
    Posts
    52

    hey, that is not a stupid question. i can't say that it wil work there as i have not tested it, maybe you should ask Mokichu, as he/she supplies the drivers

  6. #16
    ROG Enthusiast Array
    Join Date
    Jul 2018
    Reputation
    20
    Posts
    52

    Thanks Mokichu.

    Here are my findings after the sonic suite update, the app works well but resets all application profiles (in the application manager of sonic studio UWP) to "music" when launching the app. Before it would retain the profile, but upon launching all applications are set to "music". So it is buggy I shall try resetting the app and see if that works
    Last edited by DJ Asthma; 12-06-2018 at 11:24 AM.

  7. #17
    ROG Enthusiast Array
    Join Date
    Jul 2018
    Reputation
    20
    Posts
    52

    hey guys,

    Drivers by Molichu work perfectly, SS3 has a bug where it resets the application manager effects profiles to music when opening it as seen here

    https://rog.asus.com/forum/showthrea...d=1#post751410

    hopefully an update fixes this

  8. #18
    ROG Enthusiast Array
    Join Date
    Jul 2018
    Reputation
    20
    Posts
    52

    after the sonic studio update today, audio drivers work perfectly

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •