Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    1

    PG279Q Dead Pixels after 6 Months?

    I've had a random black cluster appear on my monitor only 6 months after buying it - I don't know if they are dead pixels or what but nothing I have tried made them go away.

    https://cdn.discordapp.com/attachmen...805_020920.jpg

    That's what it looks like, it's a small cluster of pixels and it sort of looks like a small line from further away. This I assume would qualify for an RMA since it's just 6 months and its multiple pixels, how long do RMA processes for these monitors generally take?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    294
    Posts
    7,381

    That looks like debris inside the display to me. Dead pixels are blocky and that looks like a fuzzy shape. Do you have any small insects about? They sometimes like warm electronics.

    Either way, I'm not sure there's much you can do whether it's dead pixels or something inside. You'd have to dismantle it to check.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Guru: Yellow Belt Array Volt PC Specs
    Volt PC Specs
    MotherboardGIGABYTE G1.Sniper Z97 ATX
    Processori7-4790K 4.0 GHz
    Memory (part number)ADATA 32GB (8GBx4) DDR3/1600MHz
    Graphics Card #1nVidia Gefroce GTX 1080 w/8 GB
    Sound CardMotherboard G1 - Creative Sound Core3D
    MonitorASUS Rog PG348Q Swift
    Storage #1250 GB Samsung 850 Pro
    Storage #22TB Western Digital Caviar Black SATA-III
    CPU CoolerAsetek 550LC 120mm Liquid Cooling
    CaseCorsair Obsidian 750D
    Keyboard Corsair K70 STRAFE
    Mouse Logitech Pro
    OS Win 10
    Network RouterASUS RT-AC88U
    Volt's Avatar
    Join Date
    Nov 2014
    Reputation
    12
    Posts
    180

    Looks like it's an insect that is stuck in there. I've had dead pixels, and red pixels, on my older LCD monitors. Those look like sharp, specific dots. In my case either Black or Red. For me, I was able to usually not notice them. Unless I was looking at them in a specific spot.

    I saw this other thread similar to this. If this is something you want to fix yourself, then it may have some suggestions as to how to get rid of it.

    https://www.eevblog.com/forum/repair...t-and-display/

    In particular the last post,

    kJelt, I had the same problem with my Dell U2412M except I made it worse by pressing the bug while it was walking around so the bug was now dead and permanently stuck between the LCD panel and the back light filter.
    I'm working from memory here as it was a few months ago but this is how I fixed mine.
    I basically stripped it down the way you did, being extra careful with the bezel and I also unscrewed the screws holding the switch PCB (It's a PITA to but it back as it has to be aligned well).
    I took the iron surround off that holds the glass in.
    With the help of another person, they held the monitor upright and tilted the top forward slightly until the LCD glass fell forward on an angle, the side of the glass with the ribbon remained where it was as a pivot point.
    The side that needs to be tilted forward is the side that doesn't have the ribbon flex cable (I can't remember if this is the top or the bottom, so you may need to turn it upside down so that the ribbon flex is closest to your table and this becomes the picot point).
    Be very careful with this ribbon flex cable as it is delicate as is the glass, it is very very thin.
    Once the glass was forward, I could easily see the bug stuck on the back light filter.
    There is not much room to get in there, the glass is leaning forward less than 45 degrees and the rest of the panel is perfectly upright, I then used a damp cotton tip to clean the bug off the back light filter.
    I then used a dry cotton tip to get rid of the moisture.
    I also noticed some dust particles located where I thought there were a couple of dead pixels for a long time.
    I cleaned these dust particles off with compressed air in a can.
    Do not touch the inside of the LCD glass to avoid finger prints.
    Put the glass upright and put the whole LCD panel on it's back.
    Align the glass to make sure it's located in the middle of the panel.
    Carefully put the iron surround back on and re-assemble the rest of the monitor.
    I had to play with the control switch PCB ass'y to get it to fit back on as the cable gets in the way and the screws are tiny.
    Once back together, my panel was clean, no dead pixels (Caused by dust) and as a bonus, I could swear the back light bleed was less noticeable and more uniform.
    But, if that sounds too difficult to do, then maybe a local shop can remove the insect for you?

    Also, if you still have insects around, then it could happen again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •