Results 1 to 6 of 6
  1. #1
    ROG Enthusiast Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    25

    Maximus VII Hero Q Code 77 after enabling M.2

    Hi,

    Motherboard: Maximus VII Hero

    In first red PCI-E slot I have an EVGA 1080Ti GPU (8x link)
    In second red PCI-E slot I have an Areca RAID card (8x link)
    In third (lowermost) black PCI-E slot I have sound card, Omega eClaro (1x link)

    I've been using the above setup for years, running OS off of Samsung PRO SSD connected over SATA.

    I just purchased SAMSUNG 970 PRO M.2 NVMe.
    I've updated the bios to 3201, because the version I've used for years didn't support M.2 NVMe fully.

    When I enabled "M.2" mode in BIOS, 'PCI Express X4_3 Slot (Black) Bandwidth', from default 'Auto Mode' to M.2 the PC restarts and ends up in Q Code 77. I have not even installed the new M.2 "gumstick", just merely changing the setting to "M.2" mode causes the MB to no longer post. I have to clear CMOS for the computer to POST.

    I tried putting in the 970 PRO just to see if perhaps the 77 error is there due to missing hardware on an active M.2 port. No difference, still 77. The "gumstick" does get warm after a while, so I assume it is operational.

    I tried removing the sound card (eClaro) but that still generates 77 error, whenever "M.2" mode is enabled. Both with and without "gumstick".

    The "M.2" setting has 4 values:
    Auto Mode - computer boots fine (M.2 slot inactive)
    X1 Mode - computer boots fine (M.2 slot inactive)
    M.2 Mode - Q Code 77 (M.2 slot active)
    X4 Mode - Q Code 77 (M.2 slot inactive)

    It almost seems that whenever more than 1 PCI-E lane activates (M.2 or X4 Mode) the Q Code 77 error happens. As long as only 1x lane operates (Auto [here I assume only 1x lane is active as eClaro doesn't use more] or X1 Modes) the MB boots.

    After fresh clearing of CMOS and setting M.2 the initial boot cycles through Q Codes rather normally. Eventually it reaches "00" and reboots. As it reboots it almost instantly goes to Q Code 77, within 2 seconds. It takes a few seconds to reach 77 after "fresh" (post M.2 setting change) reboot. Hitting Reset immediately lands at Q Code 77 again. Doing hard reboot (via PSU ON/OFF switch) also lands in Q Code 77 within 2 seconds (very quickly). Only CMOS reset saves the day.

    I saw online Q Code 77 being related to MB shorting somewhere, could I be experiencing this? In my case this only happens when I try to set M.2 Mode without any other physical hardware change.

    The computer has been in heavy use for years, could dust buildup (I did clean it today but not extensively - did not remove MB, etc) cause this?

    I also tried downgrading to 2160N (?), the first BIOS version that added full support for NVMe, same (negative) results.

    Any idea?

    Thanks.
    Last edited by skubany; 12-05-2018 at 09:46 PM.

  2. #2
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    444

    When you enable m.2 mode it disables the 1x pcie slots and drops the bottom slot to 2x giving 2x to the m.2 slot. This is why I've hesitated to use an m.2 drive with this board as I also run a dedicated sound card.

    This is taken directly from the owners manual page 1-2 and the table on page 1.26. The z97 chipset is gimped for m2 operation which sucks. Next machine I build will have at least 3 m.2 slots for my boot and primary software drives. Hope this helps.

  3. #3
    ROG Enthusiast Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    25

    I'm aware of the limitations. I know the M.2 drive will not run at max speed, but I was hoping that it will run.

    Once I have more spare time, I plan to troubleshoot this by taking the PC apart. I'll update this thread once done. If I find the problem, this might help others.

  4. #4
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    444

    You have to move your sound card to the bottom 4x slot for it to work in m.2 mode. I just added a wd black 1tb nvme ssd to my system and it works fine with an asus xonar d2x sound card in the bottom slot and if it still doesn't work then try updating the bios on your cards.
    Last edited by Puffnstuff; 12-14-2018 at 09:27 PM.

  5. #5
    ROG Enthusiast Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    25

    "bottom 4x slot" is where the sound card is plugged-in. I will try to take the computer apart tomorrow and hopefully the BIOS setting will finally work.

  6. #6
    ROG Enthusiast Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    25

    Let me update this thread.
    Got a new computer case, so finally took out the MB, cleaned it, reseated CPU, put the MB into new case and the M.2 option works!
    Well, at least the MB boots with the option set, where it did not previously. I have not actually tried to connect a drive to that port but I expect it to work now.
    So it seems it was shorting somewhere.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •