Results 1 to 5 of 5
  1. #1
    ROG Enthusiast Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    61

    Unhappy Rampage IV Extreme bios help

    Short story-

    Basically every time my computer loses electricity, I have to reset the CMOS to get back into my Bios . *And always my pet lock profile is reset to default so I reload my OC profile.

    Tonight, the computer was off but I swapped out a surge protector. *Now every time I boot the bios screen flashes a few times and then I get a black screen that says “AMERICAN MEGATRENDS” with a triangle in the top left corner. *

    I rapidly press F2 and delete to get into the bios but I can’t.

    I formatted a USB stick and loaded the latest .CAP onto it. *I also renamed it R4E. *When I put it in the top USB port and press the bios button it flashes twice and then stops flashing. *I let it sit there for 5 minutes but no luck. *I have a feeling it is not flashing the bios.

    Any advice? *Thanks!
    *

  2. #2
    ROG 師傅 Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH EXTREME
    ProcessorTHREADRIPPER 1920X
    Memory (part number)F4-3200C14Q-32GVK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Phobya Bench...let it all hang out man!
    Power SupplySeasonic SS-1200XP3
    Keyboard Logitech G810 or Fender Rhodes Electric Piano (MKI 73)
    Mouse G502 or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    481
    Posts
    13,400

    I would replace the CMOS battery.

    And follow this for formatting the USB drive....for R4E.CAP
    https://rog.asus.com/forum/showthrea...l=1#post549397

    Try other BIOS chip if all else fails

  3. #3
    ROG Enthusiast Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    61

    Quote Originally Posted by Arne Saknussemm View Post
    I would replace the CMOS battery.

    And follow this for formatting the USB drive....for R4E.CAP
    https://rog.asus.com/forum/showthrea...l=1#post549397

    Try other BIOS chip if all else fails
    Thank you for your response!
    I took my CMOS battery out this morning to bring with me to the store to make sure i bought the correct one. When I got to the store and looked at my battery, it still had the peel off film on the back of it. I cant remember the last time I replaced this battery... I cant believe I did that. I guess the Mobo will work without that battery ?

  4. #4
    ROG 師傅 Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH EXTREME
    ProcessorTHREADRIPPER 1920X
    Memory (part number)F4-3200C14Q-32GVK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Phobya Bench...let it all hang out man!
    Power SupplySeasonic SS-1200XP3
    Keyboard Logitech G810 or Fender Rhodes Electric Piano (MKI 73)
    Mouse G502 or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    481
    Posts
    13,400

    That battery powers CMOS AFAIK so if it's missing or dodgy the board wont post properly etc...BIOS settings wont stick...that sort of thing. Cold boot nightmare time.

    The film on the back wont matter..the contact is on face and edge I think...

  5. #5
    ROG Enthusiast Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    61

    Quote Originally Posted by Arne Saknussemm View Post
    That battery powers CMOS AFAIK so if it's missing or dodgy the board wont post properly etc...BIOS settings wont stick...that sort of thing. Cold boot nightmare time.

    The film on the back wont matter..the contact is on face and edge I think...

    Good to know!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •