Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Dec 2018

    Thunderbolt Ex3 Apollo Twin Connectivity

    Browsing some threads about a year ago I found out I could connect Thunderbolt devices to my PC. Since I just had an Apollo Twin fall in my lap I was ecstatic. So I set up my windows 10 PC with a Maximus 8 Hero mobo, Thunderbolt Ex3 card, a Startech Thunderbolt 3 to Thunderbolt 2 adapter, and the Thunderbolt 2 Apollo Twin.*
    This set up has worked on and off for the past year, and has been extremely frustrating. Any windows update, firmware update, or UAD software update throws it out of whack and I have to do a full clean reinstall of everything for it to recognize the device. And there are times, like right now, where even that doesn’t fix it and I’m stuck wondering what to do.*
    I’ve tested the device at length with UAD and we’ve come to the conclusion it isn’t the problem, so the issue lies elsewhere in the chain. Maybe I have a faulty Ex3 card? Or my motherboard isn’t fully compatible with the Ex3 card? Or asus needs another Thunderbolt firmware update? I’m testing the adapter today but doubt it’s tge issue, and my bios settings are fine. *
    If I get an Apollo Arrow which is a thunderbolt 3 device would that be better? Or if it’s the Thunderbolt card will I run into the same issue?
    I’m at my wits end trying to get this setup to work seamlessly, but it’s imperative that I have it. *Any advice from anyone would be greatly appreciated. *

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts