Page 6 of 9 FirstFirst ... 4 5 6 7 8 ... LastLast
Results 51 to 60 of 88
  1. #51
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    70

    Quote Originally Posted by Fullrom View Post
    Hi,

    I own the GL504GS and as many other owners im encountering a faulty internal cooling system where fans dont pick up properly or the heat sensor is not working as intended. reaching throttling after 2min of gaming. I downloaded the 305 official bios but it didnt do anything except actually raise the throttling cap so i actually recorded 98°C temps with the new bios. Is the unofficial 307 bios working on the 504gs as well??

    thanks in advance
    i dont know about your unit the bios version that was given in the link was intended for GL504GM

  2. #52
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    70

    Quote Originally Posted by JustinThyme View Post
    I’d like to understand this scenario. 2FPS drop? if it’s a drop from 4FPS I get it. If it’s a drop from 100FPS I don’t even get the presentation for resolution. A lot of variables affect small changes. Background processes utilization being one of the biggest culprits.*
    its on ROG hero 2 model that has fps drops from bios 304-305

  3. #53
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    5

    I currently own GL504GM SCAR (1060, 16GB) and updated to BIOS 307 using link provided in this thread. It fixed my issues in No Man's Sky, Witcher 3, COD4, Destiny 2, Battlefront II and Kingdom Come: Deliverance, which was dropping from regular FPS to like 20 every few seconds, but I encounter a new problem in Rocket League, which is dropping to like 5 FPS, but way less often, about once in 15 minutes (never happened before). Also I've been having sound problems, with sound randomly not working after waking from sleep or even shutdown, which BIOS update or any of the drivers didn't yet manage to fix.
    Last edited by Thorwyn; 01-10-2019 at 05:58 PM. Reason: adding scar model

  4. #54
    ROG Junior Member Array
    Join Date
    Dec 2016
    Reputation
    10
    Posts
    4

    I am sitting still on bios 304, GL504GM SCAR 2 and I am getting random issues with sound - stopping working, I am playing game ok with sound, I play video, no sound, 5 mins later with sound... randomly turning on/off, but the volume in windows is still on the same level, just not playing anything...

    I am getting more and more frustrated...

  5. #55
    ROG Enthusiast Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    26

    Quote Originally Posted by Thorwyn View Post
    I currently own GL504GM SCAR (1060, 16GB) and updated to BIOS 307 using link provided in this thread. It fixed my issues in No Man's Sky, Witcher 3, COD4, Destiny 2, Battlefront II and Kingdom Come: Deliverance, which was dropping from regular FPS to like 20 every few seconds, but I encounter a new problem in Rocket League, which is dropping to like 5 FPS, but way less often, about once in 15 minutes (never happened before). Also I've been having sound problems, with sound randomly not working after waking from sleep or even shutdown, which BIOS update or any of the drivers didn't yet manage to fix.
    Try not to confuse the GL504GM hero with the GL504GS scar as the BIOS 307 is only made for the hero version, people with the scar might proceed and wreck their machine

    Could you please detail what was happening before for you to have fps drops every 20 few seconds? was it faulty internal cooling system not picking up or was it power limitation? And as such what was the result after you updated to Vbios 307?

    Thanks!

  6. #56
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    2

    GL504GS FPS Drops

    Hey, I own a 504GS (1070 scar II) and Im trying to deal with the fps drop issue. I really cant figure it out, as long as the laptop is on flat table, everything is ok. I elevate it with a stand and the drops begin, what the hell? I have noticed that they disappear when I disable turbo boost on the CPU, but that just gimps the overall performance way too much. So, is there any hope for BIOS update that solves this? (504GS is currently on 305) Or should I just return the unit while I still can? I have tried several laptops, but this problem is really beyond me, Im worried that it might only get worse in time. Or is it just some SW bug that can be fixed?

  7. #57
    ROG Enthusiast Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    26

    Quote Originally Posted by nbs2000 View Post
    Hey, I own a 504GS (1070 scar II) and Im trying to deal with the fps drop issue. I really cant figure it out, as long as the laptop is on flat table, everything is ok. I elevate it with a stand and the drops begin, what the hell? I have noticed that they disappear when I disable turbo boost on the CPU, but that just gimps the overall performance way too much. So, is there any hope for BIOS update that solves this? (504GS is currently on 305) Or should I just return the unit while I still can? I have tried several laptops, but this problem is really beyond me, Im worried that it might only get worse in time. Or is it just some SW bug that can be fixed?

    Both GL504GS and GM have internal cooling system issues (Either fans don't pick up early and fast enough and even on permanent overboost mode you will reach throttling after 2 min of gaming either fans are constantly on max speed no matter what fan speed mode you select while on idle) that are fixable through updating the bios; Unfortunately for us GS owners there isn't any new fix for us, bios 305 from 28 november doesnt address anything. There is a thread on the forum about troubleshooting where owners share their experiences and how they either UV the cpu and gpu, removed max usage of CPU like you seem to have done, or even guide to thermal repast. The most frustrating part of this is that both machines are hyper capable of cooling properly even when pushing settings, fans are some of the most powerful on the market at the moment.
    I recently had an episode with my own GL504GS where i was able through some lucky removal of rog gaming center and something else i haven't figured yet to have the internal cooling system working as intended for a few hours, complete different story! The situation i had before I had to UV both cpu and gpu as well as removing turbo boost from cpu (you go from 3.9ghz to 2.9ghz) as well as playing in window mode as well as manually downgrading the screen resolution, that enabled me to play with cpu not going over 85° and gpu not going over 90° ever. that is my usual experience, and this is with fans in overboost mode permanently of course. Now during my episode fans were way louder, even the airflow on the right from GPU was nothing i got used to and during those few hours i could play in 144hz with no performances loss or throttling, but fans were loud af of course but hey i agreed to that i have a good headset and the only thing i care is to use my machine the way it was intended to be used


    edit: I forgot to add that for GM owners the bios 307 is fixing the issue (unofficial one that is being shared by users on a google drive in another thread, so not the official one; So it is an issue with the motherboard
    Last edited by Fullrom; 01-11-2019 at 02:58 PM.

  8. #58
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    70

    Quote Originally Posted by Thorwyn View Post
    I currently own GL504GM SCAR (1060, 16GB) and updated to BIOS 307 using link provided in this thread. It fixed my issues in No Man's Sky, Witcher 3, COD4, Destiny 2, Battlefront II and Kingdom Come: Deliverance, which was dropping from regular FPS to like 20 every few seconds, but I encounter a new problem in Rocket League, which is dropping to like 5 FPS, but way less often, about once in 15 minutes (never happened before). Also I've been having sound problems, with sound randomly not working after waking from sleep or even shutdown, which BIOS update or any of the drivers didn't yet manage to fix.
    try playing rocket league at overboost fan speed and with the sound i have same issue but just try playing music first before opening any games

  9. #59
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    2

    Quote Originally Posted by Fullrom View Post
    Both GL504GS and GM have internal cooling system issues that are fixable through updating the bios; Unfortunately for us GS owners there isn't any new fix for us, bios 305 from 28 november doesnt address anything. There is a thread on the forum about troubleshooting where owners share their experiences and how they either UV the cpu and gpu, removed max usage of CPU like you seem to have done, or even guide to thermal repast. The most frustrating part of this is that both machines are hyper capable of cooling properly even when pushing settings, fans are some of the most powerful on the market at the moment.
    I suppose you may be right. But the thing is, the FPS drops Im experiencing dont seem to have anything to do with thermals themselves. I have underclocked and undervolted the CPU and when playing Kingdom Come Deliverance, CPU temps rarely even reach 86° and the GPU is usually around 75-80°. When I lift the laptop with a stand and increase the airflow with the cooling pad, it gets even better (although loud as hell, but I dont mind that much). But once there is no hard and flat surface under the laptop, FPS drops start happening. It is just a mind boggling issue to me. How do you even sell a laptop with these issues in the first place? Just infuriating and ASUS apparently doesnt care... :/

  10. #60
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    31

    Quote Originally Posted by Vsparda View Post
    try playing rocket league at overboost fan speed and with the sound i have same issue but just try playing music first before opening any games
    I have the same sound issue. No sound after sleep on bios 306 and audio driver 6.0.1.8544.
    I had this problem before but it fixed itself after an update. It has now returned.
    Disabling and enabling the speaker under playback devices in the sound options fixes it temporarily, but it will happen again if the pc goes to sleep. Hopefully an audio driver update will fix this soon.

Page 6 of 9 FirstFirst ... 4 5 6 7 8 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •