Results 1 to 5 of 5

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Dec 2018

    Unable to install drivers for RTX 2080 Ti


    I'm trying to upgrade to a ASUS GeForce RTX 2080 Ti Turbo 11GB from an ASUS ARES III. But when I install the Nvidia drivers the system goes unstable and crashes to a black screen.

    The process I'm following:
    1) Clean out current drivers using Windows uninstall and/or DDU
    2) Restart system to confirm stability - runs ok in 1024 * 768
    3) Start install of NVIDIA drivers 411.63 (tried ASUS 416.34 as well), drivers seems to installing ok until system is either automatically rebooted by install process or crashes. When rebooting, the system gets past Bios boot and then you can see Windows logo for a few seconds and then it goes to black screen.*
    4) GOTO 1

    Things I have tried:
    1) Switched to onboard graphics - totally fine! - So no inherent MB / MEM /Monitor issue
    2) Booted with RTX with no drivers installed - system is stable
    3) Booted with RTX into safe mode - system is stable
    4) Updated MB Bios - 2.17.1246 5) Build a 100% clean windows install from downloaded Windows ISO (build 17763.rs5_release.180914-1434) * * *- all is fine until I try and install the drivers.
    6) Changed bios graphics setting from auto to PEG and back. ***

    1) Either the driver installation is not completing correctly
    2) or there is an inherent problem with the driver. My kit is not that old so would not expect any compatibility issues???

    Intel Core i7-6700K Quad Core CPU
    Corsair *PC4-21300 2666MHz DDR4 RAM
    Seasonic 1050W X-Series *

    Has anyone seen this? Any suggestions on what else to try? (I know I know - should not have switched from AMD to NVIDIA ;-) ) *


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts