Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Dec 2018

    Unable to install drivers for RTX 2080 Ti


    I'm trying to upgrade to a ASUS GeForce RTX 2080 Ti Turbo 11GB from an ASUS ARES III. But when I install the Nvidia drivers the system goes unstable and crashes to a black screen.

    The process I'm following:
    1) Clean out current drivers using Windows uninstall and/or DDU
    2) Restart system to confirm stability - runs ok in 1024 * 768
    3) Start install of NVIDIA drivers 411.63 (tried ASUS 416.34 as well), drivers seems to installing ok until system is either automatically rebooted by install process or crashes. When rebooting, the system gets past Bios boot and then you can see Windows logo for a few seconds and then it goes to black screen.*
    4) GOTO 1

    Things I have tried:
    1) Switched to onboard graphics - totally fine! - So no inherent MB / MEM /Monitor issue
    2) Booted with RTX with no drivers installed - system is stable
    3) Booted with RTX into safe mode - system is stable
    4) Updated MB Bios - 2.17.1246 5) Build a 100% clean windows install from downloaded Windows ISO (build 17763.rs5_release.180914-1434) * * *- all is fine until I try and install the drivers.
    6) Changed bios graphics setting from auto to PEG and back. ***

    1) Either the driver installation is not completing correctly
    2) or there is an inherent problem with the driver. My kit is not that old so would not expect any compatibility issues???

    Intel Core i7-6700K Quad Core CPU
    Corsair *PC4-21300 2666MHz DDR4 RAM
    Seasonic 1050W X-Series *

    Has anyone seen this? Any suggestions on what else to try? (I know I know - should not have switched from AMD to NVIDIA ;-) ) *


  2. #2
    Banned Array JustinThyme PC Specs
    JustinThyme PC Specs
    Laptop (Model)G752VY-DH72
    MotherboardRampage VI Extreme
    ProcessorI9 9940X
    Memory (part number)64GB DDR4 8x8 Corsair Dominator Platinum 3800 MHz @ C17
    Graphics Card #1ASUS Strix 2080Ti O11G @ 2.1GHz
    Graphics Card #2ASUS Strix 2080Ti O11G @ 2.1Ghz
    Graphics Card #3ROG Nvlink
    Graphics Card #4Have to feed animals
    Sound CardExternal Audioengine D1 24 bit 192kbps DAC
    MonitorASUS PG348Q @ 100Hz
    Storage #1Intel 905P 480GB U2 flavor
    Storage #2Samsung 850 EVO 1TB X2 in RAID 0, 960 PRO 1TB DIMM.2_1
    CPU CoolerHeatKiller IV PRO and VRM blocks ,Dual D5 PWM serial, 2X 480, 1X 360 RADS
    CasePhanteks Enthoo Elite 8X LL120 PWM, 3X LL140 PWM, 12 SP120 PWM 1x AF140 PWM
    Power SupplyCorsair AX 1500i
    Keyboard ASUS Claymore
    Mouse ASUS Spatha, Logitech MX Master
    Headset Sennheiser HD 700
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Audioengine A5+ with SVS SB-1000 Sub
    OS Win10 Pro 1809
    Network RouterNetGear NightHawk X10
    Accessory #1 NetGear Prosafe 10GBe Switch
    Accessory #2 Qnap TVS-682 NAS modded with I7 CPU

    Join Date
    Nov 2013

    If you had another Nvida card laying around I would suggest that. Have you installed GPU tweak? ASUS cards do not hit any higher than reference without the software. A bit of a bugger but it works.*

    With a clean install and no traces of previous drivers there should be zero issues. Have you tried different driver versions? Make sure that the one you are using is recent enough that the 2080ti is included.

    Hell I still can’t wrap my head around the cost of GPUs these days courtesy of mining. I bought two 1080TIs for less than one 2080Ti $650 each) but even those are outrageous now. *Card makers need to make cards that mine better but suck at graphics performance and vice Vera’s so they are affordable to the masses. There are a few like the Volta but they aren’t buying those next as they are double what the 2080Tis are.*

  3. #3
    New ROGer Array
    Join Date
    Dec 2018


    Replaced the old motherboard with an ASUS Maximus XI and problem went away!!!

  4. #4
    ROG Guru: Gold Belt Array Menthol PC Specs
    Menthol PC Specs
    MotherboardM 10 Apex / XI gene
    Processor8700K / 9900K
    Memory (part number)2x8 Gskill Trident Z 4266/2x2x8 Gskill Trident Z 4500
    Graphics Card #1RTX 2080ti / GTX 1060
    Sound CardSoundBlaster Ae5 / Onboard
    MonitorBENQ 32" 4K
    Storage #1Intel 900p 480GB/Samsung 960 Pro 1TB
    Storage #2Intel 750 1.2TB/Plextor 1 TB 2X 950 Pro
    CPU CoolerCorsair H150i AIO / H1110i
    CaseCorsair 740 ? Lian Li Air
    Power SupplyCorsair AX 1200i / AX 1200i
    Keyboard Corsair
    Mouse ASUS Strix
    Headset HyperX Cloud Alpha
    Mouse Pad ASUS
    Headset/Speakers Logitech Z906
    OS 10 X64 Pro
    Network RouterVerizon Fios
    Accessory #1 Intel Wifi BT pcie card
    Accessory #2 Red Bull
    Accessory #3 English Breakfast Tea
    Menthol's Avatar
    Join Date
    Jan 2012

    That's one way of fixing an issue, doesn't answer what your issue was but good for you. new hardware for a new year

  5. #5
    ROG Enthusiast Array
    Join Date
    Oct 2011

    yeah I am having the same issue myself. Tried card on two rigs same thing.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts