Results 1 to 7 of 7
  1. #1
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    5

    Angry Motherboard 2nd RMA - Almost 3rd.. Still Issues

    Hi there,

    Generally I'm happy with the experience I have with Asus, the products are of high quality and the customer service tends to be easy to deal with and provides the information I need. However, I've had one particular experience that has been far below my expectations.

    I purchased/owned a Asus ROG Rampage V Extreme motherboard for about 3.5 years with no problems. Then on one day it decided to stop working - it would intermittently power on (most of the time it didn't power on at all). I tried all the usual troubleshooting steps i.e. clearing CMOS, replacing CMOS battery, switching bios etc but nothing worked. So I then decided to return it to Asus for a replacement (I knew it was out of warranty but I preferred to purchase one through them anyway).
    I then sent the motherboard to Asus and paid for the replacement board via RMA. The replacement board I received physically didn't appear to be in the best condition as it had marks on the plug inputs "extreme" cover and there was some strange liquid that had dried on a portion of the face area of the motherboard. I didn't inform Asus of this at the time as I was so happy to finally have a motherboard back.
    I installed the replaced motherboard (which was obviously refurbished) and it worked fine for about 2 months, then the same problem occurred. My motherboard went dead again and wouldn't turn on. I tried out the usual troubleshooting procedures but still no luck.
    I was fairly frustrated at this time as I only just recently received a replacement board. I then began another RMA and sent the motherboard back. This time, the motherboard was under the 3 month warranty they give on replacement motherboards so I was sent another motherboard at no extra cost. I tried my best to ask for a different model or a brand new motherboard but Asus would NOT accept my request on several occasions which was extremely irritating considering this was the 2nd RMA!
    I received my 2nd replacement motherboard yesterday and it looks in decent condition (it does still look to be refurbished though). I tried installing and running it and it took quite a few reboots and CMOS clears to get it to boot stably. I then noticed in my task manager that my motherboard wasn't recognizing all the RAM I have physically installed. So I tried placing different combinations of the RAM in different dimm slots and it appears that 2 certain dimm slots are faulty and wouldn't register the RAM - all the other dimm slots are fine and work with my RAM.

    I'm at a point now that I'm very frustrated at Asus and their ability to provide a quality return process. I spent a significant amount of money on the motherboard originally and I expect the price I paid to reflect a quality company.

    I'm hoping someone at Asus can help me with this issue and provide a solution that will make me not want to change brands.

    Please note: this was all through the North American Asus repair centre (Jeffersonville, IN). I have several RMA numbers that I can provide.
    Last edited by panc8kes; 01-03-2019 at 02:26 AM. Reason: Provide further details.

  2. #2
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    5

    Hi,

    Is there an Asus rep I can message that will help me with this situation? Its extremely frustrating and is a poor reflection on Asus..!

    Thanks.

  3. #3
    Moderator Array
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    9

    Hi Panc8Kes
    Good day , I am so sorry to hear such experience from you. Please pm me your RMA No. to help me pass to relevent department, thank you.

  4. #4
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    5

    Hi Alvez,

    I PM'd you at the end of last week and have yet to receive a response - just wondering when I should be expecting one.

    Thanks.

  5. #5
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    5

    Hi Alvez,

    I'm still waiting on a response and it's been over a week and a half since your initial reply.

    Any help will be appreciated.

    Thanks.

  6. #6
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    5

    Angry

    Hi Asus reps,

    Another update, my motherboard has completely died AGAIN. It's the same issue as the last 2 times. I've been in touch with Alvez but he is rather difficult to understand due to his english. Is there another Asus rep I can get in touch with? I'm keen to get a DIFFERENT model motherboard because as you can understand I don't have any confidence in the Rampage V Extreme anymore.

    Please help.

    Thanks.

  7. #7
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    300
    Posts
    7,440

    *off topic discussion post(s) deleted*
    *just a reminder that services inquiries is not a discussion area. Do not post in a thread unless you are the OP or a representative of ASUS, thanks*
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •