Results 1 to 4 of 4
  1. #1
    ROG Enthusiast Array
    Join Date
    Dec 2017

    Help. Constant BSOD because mtoskml.exe


    I'm really desperate because I get BSOD because of this .exe.

    I went into mimidump because I made a clean install of windows 10 with latest version because of this and still I get the same error. Bios and drivers updated (only I didn't install realtek sound driver cause I don't use It).

    The exact error in the dumpfile is mtoskskml.exe and sometimes it is mtoskml.exe+2d0d66.

    Everywhere in Internet I can't find specific help. That is about kernel, reinstall OS, update drivers,... I did all that. No overclock in my system which is:

    Z370-E Strix Gaming.
    16GB Corsair Vengeance.
    RTX 2080.
    M.2.960 Pro.
    M.2. 960 Evo.

    Some one can help me with this?

    Thank you

  2. #2
    ROG Guru: Gold Belt Array Menthol PC Specs
    Menthol PC Specs
    MotherboardM 10 Apex / XI gene
    Processor8700K / 9900K
    Memory (part number)2x8 Gskill Trident Z 4266/2x2x8 Gskill Trident Z 4500
    Graphics Card #1RTX 2080ti / GTX 1060
    Sound CardSoundBlaster Ae5 / Onboard
    MonitorBENQ 32" 4K
    Storage #1Intel 900p 480GB/Samsung 960 Pro 1TB
    Storage #2Intel 750 1.2TB/Plextor 1 TB 2X 950 Pro
    CPU CoolerCorsair H150i AIO / H1110i
    CaseCorsair 740 ? Lian Li Air
    Power SupplyCorsair AX 1200i / AX 1200i
    Keyboard Corsair
    Mouse ASUS Strix
    Headset HyperX Cloud Alpha
    Mouse Pad ASUS
    Headset/Speakers Logitech Z906
    OS 10 X64 Pro
    Network RouterVerizon Fios
    Accessory #1 Intel Wifi BT pcie card
    Accessory #2 Red Bull
    Accessory #3 English Breakfast Tea
    Menthol's Avatar
    Join Date
    Jan 2012

    You say no overclock, is bios set to defaults (F5) no XMP?
    Try one stick of memory at a time to check if you have a bad memory module

  3. #3
    ROG Enthusiast Array
    Join Date
    Dec 2017

    Quote Originally Posted by Menthol View Post
    You say no overclock, is bios set to defaults (F5) no XMP?
    Try one stick of memory at a time to check if you have a bad memory module
    Thank you. Yes i tried that because I had XMP but no luck with it. Also I separated both modules and test both and all ok.

    Apart from the Dumpfile the error that the BOSD says is:

    DRIVER_POWER_STATE_FAILURE. And the Dumpfile says mtoskml.exe.

    I plugged out my USB devices (mouse and keyboard, hard drives). But I need one keyboard USB dongle to operate.

    In Bios almost all setings are at stock-auto cause it's a confusing world. I didn't have this issues before the summer and only updated the 2080 that works well even in hard benchmarks when the computer works.

    Any other idea?

  4. #4
    ROG Guru: Green Belt Array panzlock PC Specs
    panzlock PC Specs
    Laptop (Model)ASUS X553M, ASUS Zenpad 10 Z300M, ASUS X542BA-DH99
    MotherboardASUS P8Z68-V LX, ASUS Z170-A, ASUS ROG Strix B350-F Gaming
    ProcessorIntel i5-2500K, Intel i7-6700K, AMD Ryzen R7 1700
    Memory (part number)8GB Kingston 1333MhzDDR3 C9, 16GB G.Skill Aegis 3000Mhz DDR4 C16, 16GB G.Skill Trident Z 3200Mhz C16
    Graphics Card #1EVGA GTX 560Ti, ASUS ROG Strix GeForce GTX 1070 O8G OC, Sapphire Nitro+ RX Vega 56
    Monitor32" INSIGNIA 720p, 32" Samsung 1080p C32F391FWN, 32" ASUS 1440p VA32AQ
    Storage #1Seagate 150GB 7200RPM, Samsung 850 EVO 250GB 2.5" 6Gb/s Solid State Drive (X2)
    Storage #2Seagate 500GB 7200RPM, WD Blue 3TB - 5400 RPM SATA 6 Gb/s 64MB Cache 3.5 Inch
    CPU CoolerDeepcool GAMMAXX 300, Deepcool Lucifer V2, Wraith Spire
    CaseAntec Sonata, Deepcool Dukase V1, Deepcool Dukase V3
    Power SupplyATX 650, EVGA SuperNOVA 850 P2 (X2)
    Keyboard Logitech K220, MSI Interceptor DS4200 (X2)
    Mouse Microsoft 1850, Microsoft 4500, Gamdias Erebos LE, MSI DS 100, Redragon M601 Centrophorus
    Headset/Speakers Logitech Z313, Logitech Z506 (X2)
    OS Windows 10 Home X64, Windows 10 Pro X64 (X2)
    panzlock's Avatar
    Join Date
    Nov 2016

    Other things you might try:

    1.) Update BIOS;
    2.) Reinstall/update all your drivers;
    3.) Memtest your RAM.
    I'd like to deploy my troops in her country.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts