Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Enthusiast Array
    Join Date
    May 2016
    Reputation
    10
    Posts
    45

    Question G752VT - Sonic Suite V2.4.13 - wrong driver version?

    Using a ROG G752VT laptop. I tried to install the newest version of Sonic Suite (V2.4.13 - Asus Support uploaded on Jan 10th). I uninstalled the previous version, but when installing the newer one it failed with an error that I had the wrong driver version.

    I was able to reinstall the older one and it still works fine. Is anyone else having problems with their update?

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2012
    Reputation
    55
    Posts
    395

    The Sonic Suite V2.413 is requiring the Reltek driver R2.82 be installed first. The driver can be found at www.Realtek.com.tw/downloads. Please choose the correct driver for your OS.

    Works fine on my G752VSK. It bears the question why Asus hasn't updated their audio driver yet.

  3. #3
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    The audio driver from the support page has been tested to work with Sonic Studio. Please make sure the driver is installed first and have Realtek audio set as default, in case you have another USB headset/audio device connected instead.

    Are there any issues with the current audio driver?

  4. #4
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2012
    Reputation
    55
    Posts
    395

    The audio driver on the ASUS G752VSK download page is version 6.0.1.7960 from Nov 2016. The newest audio driver from Realtek is version 6.0.1.8186 from June 2017. The Sonic 2.4.13 software will not install with the audio driver version 6.0.1.7960. At the end of the installation process, it halts and displays message that a newer audio driver is required. After installation of the audio driver version 6.0.1.8186 (downloaded from Realtek), the Sonic 2.4.13 software will install properly. The new Sonic software actually sounds better than the earlier version.

    The audio driver provided on the ASUS G752VSK download page should be updated to the newer version 6.0.1.8186 if ASUS is providing the Sonic 2.4.13 software download, then a statement must be added to also require download of the updated audio driver.

    As for ASUS testing this beforehand, I can only state what I have found on my G752VSK.

  5. #5
    New ROGer Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    4

    Bug in Sonic Studio 2 profiles?

    It is also working on the G752VT (downloaded from here: https://www.asus.com/de/ROG-Republic...Desk_Download/) with the newest Realtek driver 6.0.1.8198!

    The old version, delivered with my G752VT, didn't work while browsing or lisening music on youtube after the creators update. But strangly worked while gaming.
    No it is woking as it should when listening music and playing games :-)

    But it seems that there is a bug. If you open the Sonic Studio and select the profile "music" or "costum", the surround button and selecting a preset at the equalizer has no function. But if you click on the equalizer button and then select one of the presets it suddenly works.

    A small workaround is to select one of the other profiles "gaming" or "movie".

    Even if you register a new profil (the small plus under the profile) from the faulty or the working profile the behavior will be the same. I mean if you register a new profile from a faulty one, the new one will have a none working equalizer and surround button.

    What i have tried: Deinstall Sonic Studio 2, then deinstall Realtek, delete all leftovers in the registry and in "AppData" and then reinstall the Realtek driver and the new Sonic Studio 2.


    Did anyone else have this effect/bug?


    Best regards!
    Last edited by christian86; 01-16-2018 at 10:36 PM.

  6. #6
    ROG Enthusiast Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    25

    I have not been able to find a driver which works with the sonic suit in the asus g752vm page.

    Could anyone please share a link to a working version?

  7. #7
    ROG Enthusiast Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    25

    Quote Originally Posted by MoKiChU View Post
    Hi,

    You can use this one (work too on notebook) : https://rog.asus.com/forum/showthrea...HD-Audio-(HDA)

    Use FIRST INSTALL/CLEAN INSTALL tutorial of this thread to install the latest Realtek HD Audio Drivers v6.0.1.8586 WHQL with Realtek HD Audio Manager + Sonic Studio II v2.4.13.0 (Optional) & Sonic Radar II v2.1.3401.0 (Optional)
    Thank you very much for your reply.

    I have followed your guide but I have this issue: As soon as I install the sonic studio suite II, I loose the sound... Actually, it works for a bit after launching windows but then it stops.

    The sonic studio II from your post also install the sonic radar. I can actually access sonic radar program but the sonic studio does not open.

    Any advice you could give me would be most welcome.

  8. #8
    ROG Enthusiast Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    25

    It returns but it sounds rather horrible... I will try those. Thank you very much.

  9. #9
    ROG Enthusiast Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    25

    No... The Sonic studio HDA 2.2.3601 is not compatible with the realtelk 6.0.1.8586 driver.

    Incidentally, the driver store explorer tells me I have two realteck semiconductor corp: hdxasnahi.inf with 6.0.1.8586 driver and hdxrt4.inf 6.0.1.7945 driver. Even though the later I deleted it before installing the new driver.

  10. #10
    ROG Junior Member Array
    Join Date
    Oct 2017
    Reputation
    10
    Posts
    2

    I have exact the same issue. I managed to download and install Sonic Studio2 by using the old Audio-driver. After that, there is no sound at all. SS2 shows up in the tool bar, but when i try to start it to get it configuerd, it won´t start...

    I had it installed once, when i bought my 752VL, but I had to reinstall everything. Without SS2, the sound of the 752 is so terrible, that I prefer to use an external system. With SS2, I had found out an EQ curve, that soundend pretty decend.

    So, I hope, there´s a solution.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •