Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Jan 2019

    Ethernet problem on X299-E GAMING

    I chose the Asus ROG STRIX X299-E Gaming for my new rig I built about 2 months ago. After the lego class she posted as expected. OS install, drivers, usual stuff but one thing I could not understand - the ethernet port was not working. Thought it's a driver fault, so I updated the chipset and LAN drivers to the latest. Still not working. Device manager - hard forcing it to recognize the port by deleting and scanning for hardware changes. No result. Clean OS re-imaging, installed only the chipset and LAN drivers (thought it could be a problem with the driver install sequence). Nope.

    I gave up on fixing it and bought an Asus - XG-C100C network card to try to workaround my issue and it solved the problem. Now I was certain it is a defect hardware.

    After a long month of researching, I only found one post on a random forum that XMP profiles might disable the ethernet port if enabled. I was sure I had not enabled XMP or turbo, nor did any overclocking ever since I built it (to make sure I have a stable system before losing any warranty with overclocking). My last hope was gone.

    Is it really just a defect hardware issue? Have you guys heard anything like this before? Do you know what can cause this problem?
    I've contacted the retailer, we agreed on them taking the board back. Before I do so, I thought I ask the community first.

    Last edited by MenzoAS; 01-08-2019 at 12:53 PM. Reason: grammar

  2. #2
    ROG Guru: Brown Belt Array LiveOrDie PC Specs
    LiveOrDie PC Specs
    ProcessorIntel Core i9 7980XE Custom IHS @ 4.6Ghz 1.23v
    Memory (part number)G.Skill Trident Z RGB F4-3000C14D 64GB
    Graphics Card #1AORUS GeForce RTX™ 2080 Ti XTREME WATERFORCE WB 11G
    MonitorLG 4k 43inch
    Storage #1Samsung 960 Pro NVME 512gb
    Storage #2Samsung 850 Evo 1TB x 2
    CPU CoolerEK-Velocity , EK-CoolStream PE 360, XSPC TX240 Ultrathin, EK X-RES 140 Revo D5 RGB PWM
    CaseCorsair Obsidian 500D SE ATX-E Modded
    Power SupplyCooler Master Vanguard Series 1000W
    Keyboard Logitech G910
    Mouse Logitech G900
    Headset Razer Tiamat 2.2 v2
    OS Windows 10 x64
    Network RouterNetGear
    LiveOrDie's Avatar
    Join Date
    Dec 2011

    RMA the board it sounds like its faulty.

  3. #3
    ROG Junior Member Array
    Join Date
    Jan 2019

    Thank you for your advice, will do so. (Sorry for the late response, just got back home from a trip.)

    Currently talking to the retailer. I'll post more info once I got a new one / it back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts