Results 1 to 9 of 9
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    68

    Serious Boot problem with ROG Strix GL703GS Scar Edition

    Today i got a brand new GL703GS Scar Edition without windows and when i tryed to boot an USB with win10 i was shocked that nothing really worked.
    I can boot same USB on my old G750GS and my Desktop but the GL703GS does not recognize it. When i spend some time inside the bios and i notice
    that some of the option are actually missing, it seems like the BIOS is not full. For example there should be a CSM option but its simply not there...

    I am not able to boot any USB drive (tried with 3 different) and right now i have brand new laptop without windows and i have no idea what to do...



    Last edited by matau; 07-03-2018 at 08:27 PM.

  2. #2
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    99
    Posts
    2,134

    Hi,

    Try to check under the 'Security' menu to disable 'Secure Boot Control' and then look under the 'Boot' menu to see if there is a 'CSM Support' option you can enable.
    Hope this helps, but I'm comparing with the GX501VIK, so not sure if anything will be different, but don't think so.

    You can set the boot priority in the bios after you save and exit and go back into the bios, but try tapping the 'ESC' key after powering up to catch the boot menu if you prefer.

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    68

    By Default the Secure Boot Control is set to Disable... and yeah i know it weird but there is no CSM Support...
    Also i tried HARD reset but didn't but the results are same...

    Last edited by matau; 07-03-2018 at 08:47 PM.

  4. #4
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    99
    Posts
    2,134

    Ok, looks like your bios is set up differently and you have the latest version.
    Assume nothing promising appears under the 'Security' menu?
    If necessary, consider checking with your local ASUS support to see if a new bios will or can be released to resolve this?

  5. #5
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    68

    Nothing helpful... I guess i will go tomorrow and return the unit to the seller and ask for a new one...

  6. #6
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    99
    Posts
    2,134

    Quote Originally Posted by matau View Post
    Nothing helpful... I guess i will go tomorrow and return the unit to the seller and ask for a new one...
    Curious if you plan to ask for the same model or different model.
    Would not be too surprised if all these GL703GS models were the same, so just something you may want to be prepared for if you haven't already.
    Hopefully I'm wrong, or a new bios will be released soon to solve it (no idea about this right now).

  7. #7
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    68

    Well i will ask for same model, i talked with ASUS support and they said that its quite possible that mine is defected and they advice me to go to the reseller and change it with other.

  8. #8
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    68

    The solution was simple, i just had to press ESC while the PC started and i got the boot menu with working USB drive, typing from my new gl703gs )

  9. #9
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    6

    Rog 703gs Hard and battery

    You unit is dischargine while playing games instaled on sshd? I have same unit, and when i play games that are instaled on sshd, batery drops from 100% to 85 in under 1 hour. When i play games from ssd, everything's ok, but in some games, sshd just creates frame drops to 0 for like 1-2 seconds. As i saw in rog center, while freezing for like 2 seconds, everything gets low, even cpu voltage, gpu voltage, cpu usage, gpu usage, all of them. I should mention tha i don't have any kind of throttling, temps are fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •