Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    1

    Display issue on Gl752V!!Help!

    So I disassembled my laptop to clean everything out an once I had everything back together there was still power, fans, lights, ect turned on except for the display. I tried to unplug an plug everything back in an it worked but the second I turned it off to put in a hdd an power it back on there was no display again but it remains no display even with hdd out of laptop even though laptop is on an receiving power. Power and scroll lock led lights are on An fans spin as well.*

    I’ve checked the ram
    Tried to hard reboot
    Tried to reset cmos
    Tried to disconnect an reconnect everything
    Tried the display enabling function keys
    Tried pulling battery and clearing excess voltage
    Tried following lcd cable into lcd to check for breaks an it’s in perfect condition.
    I’ve tried connecting hdmi to my tv to check for signal an I get no display on tv.(there’s no vga port on laptop)
    *
    *I’m starting to think it may be stuck in hibernation but can anyone else give me an idea of what’s going on? There are no signs of shortages an all the heat sinks have been re-pasted before any of the issues happened. *
    Last edited by DiluteBeaver; 01-10-2019 at 10:50 AM. Reason: Forgot informstion

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •