Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    14

    ASUS EZ UPDATE Back from the Dead - and now spamming chipset updates?!?!?

    This Software was basically dead for a decade, i wrote a rant on asus feedback page and 2 days later it starts spamming my computer with INTEL CHIPSET UPDATES I just now received the 4th update (or repeated attempt) in a week!!

    No for real ..it detects on the latest Windows 10 Enterprise , Insider Fast Ring Build the following (completely outdated ?? year 2016/named Intel 200 Series LPC Controller under system devices running chipset driver version 10.1.1.38) and wants to update it to 10.1.1.44 with a size of 5.083 KB which is btw also completely outdated from 2017

    Now what the actual F ...Intel 200 ? This is a Strix 370 Z - F Gaming mainboard which is a Intel 300 series chipset... Dunno if thats normal but
    its seems a bit odd. And of course i have the actual motherboard drivers installed.

    Anways the EZ Updater then proceeds doing so when you agree to update and ends with stating that the update is complete and im pretty sure it does NOTHING because the driver version stays the same after completing the process and when u refresh EZ Update the update is there again. So it not only fails to install but also gives false feedback about a succesful installation,. It also does NOT ask for Admin permissions to install the driver. So im pretty sure this is just another one of these typical ASUS software desasters.

    I havent seen this EZ Updater doing anything EVER on any ASUS system i owned in 10 years or more.. So that its now coming back
    from the dead is more troubling than actually pleasing, did you fire the guy reponsible for updating this and put a new one in charge or what?

    And even if this is a user error and i have not installed the correct chipset driver...lets just theorize here... why does it start to bug me now about something that must have been the case for months or even years depending on how long the OS was installed.

    Also theres this article concerning the currently installed driver, so im wondering why this is the case , shouldnt all of this be adressed by installing the manufacturers chipset drivers package from the downloads page in the first place, or are these components to be ignored and not part of that package or what? The package that i have installed is: Version 1828.12.0.1152 2019/01/24
    Since these drivers are also SMBUS relevant and this board is SMBUS 3.0 and the drivers which are present are SMBUS 2.0 drivers (afaik) and these components are specific for temperature and voltage control on a motherboard i wonder what the hell is this intransparent mess?
    Is this how things should be ? Its very confusing. Is it for KABY LAKE backward compatbility or or is only the storage controller part of the 300 chipset and the rest of this board is based on 200 chipset? This system runs a COFFEE LAKE processor.

    This article says otherwise:
    https://www.intel.com/content/www/us...-software.html
    Also Intel itself says that the driver ASUS wants to install on my system is for INTEL COMPUTE CARDS , i dont run such a thing.

    And in general THIS is a very noteworthy article about the changes to the windows 10 driver architecture and intels adapation
    of the DCH Driver model in November 2018:
    https://www.intel.com/content/www/us...rporation.html

    In which way are ASUS drivers compliant to this new model?

    Intels Driver Update Utility does NOT detect any needs to update my chipset driver at all btw
    and it identifies the Z370 as intel 200 chipset

    Click image for larger version. 

Name:	2019-03-23.png 
Views:	0 
Size:	290.1 KB 
ID:	79652
    Click image for larger version. 

Name:	2019-03-23 (1).png 
Views:	0 
Size:	43.7 KB 
ID:	79653
    Last edited by TheInfidel; 03-23-2019 at 07:46 PM.

  2. #2
    ROG Member Array evo4ever86 PC Specs
    evo4ever86 PC Specs
    MotherboardASUS Maximus X Hero Z370 (1801 BIOS)
    ProcessorIntel Core i7 8700K Coffee Lake @ 5100MHz
    Memory (part number)16GB Kingston Hyper X Fury @ 3333mhz C16
    Graphics Card #1MSI GeForce RTX 2080 Gaming X Trio @ 130/1000
    Sound CardIntegrated Realtek HD 7.1
    MonitorLG 42' Inch 4K UHD @ Game Mode
    Storage #1Samsung SSD 960 EVO M.2 NVMe 250GB
    Storage #22x 256GB Samsung SSD 850 EVO @ RAID0
    CPU CoolerCorsair H115i Extreme AIO
    CaseNZXT Noctis 450 MIDI
    Power SupplyCougar GX V3 1050W Plus Gold Modular
    Keyboard Corsair Gaming K63 RGB with Corsair K63 Lapboard
    Mouse Corsair M65 RGB
    Headset Corsair HS60 7.1 Gaming Headset
    Mouse Pad N/A
    Headset/Speakers Corsair HS60 7.1 Gaming Headset / No Speakers
    OS Windows 10 Pro
    Network RouterISP Provided DOCSIS 3.1 Cable Router
    Accessory #1 256GB SANDISK SDCZ880 Extreme Pro USB 3.1 SSD Flash Drive
    Accessory #2 Bluetooth USB Dongle

    Join Date
    Jan 2019
    Reputation
    10
    Posts
    22

    Just download the motherboard drivers manually. I never use EZ UPDATE. Go to your mobo's support page and download them there. I've got a Maximus X Hero Z370...

    Click image for larger version. 

Name:	mobojpg.jpg 
Views:	0 
Size:	63.7 KB 
ID:	79662

    I'm not quite sure why it's dated 1968 lol. On the support page its dated 20/03/2019.
    Last edited by evo4ever86; 03-25-2019 at 07:02 AM.

  3. #3
    ROG Member Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    14

    Quote Originally Posted by evo4ever86 View Post
    Just download the motherboard drivers manually. I never use EZ UPDATE. Go to your mobo's support page and download them there. I've got a Maximus X Hero Z370...


    I'm not quite sure why it's dated 1968 lol. On the support page its dated 20/03/2019.

    Did you read my article. This is not primarily about chipset drivers..this is about AZ EZ UPDATE coming back from the dead and trying to push a low level driver onto the system and failing at every aspect. Also in the wake of ASUS LIVE UPDATE having been hijacked by Shadowhammer Hackers this is TROUBLING. https://www.asus.com/News/hqfgVUyZ6uyAyJe1

    Also i have the intel driver package installed: Version 10.1.17809.8096 2019/01/24 which is the latest on ASUS download page
    and it does NOT update the driver popping up in EZ Update ( a utility which has never worked or shown any updates for me until i made this post)
    It is the completely WRONG Driver . Yours is correctly showing Intel 300 chipset. Mine is showing Intel 200 chipset (on a Z 370 STRIX) for that specific set of chipset subcomponents.

    Additionally i have checked this:
    https://downloadcenter.intel.com/dow...product=125903
    And when trying to install chipset inf utility it asks me if i want to DOWNGRADE, which makes no ****ing sense.

    The 1968 Date is a Intel reference to the year INTEL was founded and to lower the rank of the driver so it will be overwritten by newer versions (which obviously is a bull**** method)...the driver you use is from 2017 mine is from 2016.

    The sloppyness in which INTEL and ASUS handle their **** is just breathtaking.
    Last edited by TheInfidel; 03-27-2019 at 11:14 PM.

  4. #4
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    1

    Besser spät als nie ^^

    Servus,

    Ich weiß der Post ist etwas älter aber ich Hoffe dennoch dir helfen zu können

    von deinen Screenshots konnt ich sehen das du Deutscher bist , hatte das selber Problem auch vorhin, Irgendwie passiert ist das ein 200 Chipsatz installiert wird obwohl wir 300 Benötigen Deinstallier im Geräte Manger den Treiber, aber starte nicht neu und Installier den Treiber von Asus.

    Dann sollte bei dir im geräte Manger 300 Series stehen und das Problem weg sein hoffe ich konnte helfen, bei weiteren Frage meld dich.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •