Page 1 of 18 1 2 3 11 ... LastLast
Results 1 to 10 of 176
  1. #1
    Administrator Array MasterC@ROG's Avatar
    Join Date
    Aug 2014

    ROG Armoury II V3.00.16 [Report any issues here]

    Armoury II 3.00.16 is now available.
    Click image for larger version. 

Name:	3.00.16.JPG 
Views:	92 
Size:	126.5 KB 
ID:	78139
    Manual download here:

    Release Notes:
    Improved performance
    Added support for ROG GLADIUS II WIRELESS
    Added support for ROG STRIX FUSION 300
    Added support for ROG STRIX CTRL

    Execute UpdateInstaller.exe to update.

    When reporting issues, please install the latest software and firmware, then provide as much info as possible to help us understand your setup.
    Include the following info:
    1. PC / Laptop
    2. Aura Sync products
    3. 3rd-party peripheral, audio, or lighting software
    4. Wired / wireless connection
    5. Reinstalled Armoury II?
    6. Reinstalled Windows?
    7. WIndows version & build
    8. Previous version of firmware or software that worked as expected
    9. Clarify your issue as clearly as possible.
    10. Any screenshots of issue
    Last edited by MasterC@ROG; 01-22-2019 at 03:35 AM.

  2. #2
    ROG Member Array Shadow530 PC Specs
    Shadow530 PC Specs
    Laptop (Model)-
    MotherboardASUS ROG STRIX B550-F Gaming
    ProcessorAMD RYZEN 7 3700X
    Memory (part number)32GB Corsair Vengenance Pro RGB 3466Mhz
    Graphics Card #1ASUS ROG STRIX GeForce RTX 2080Super
    Graphics Card #2-
    Graphics Card #3-
    Graphics Card #4-
    Sound CardOnboard
    Storage #12x Samsung 970 Evo NVMe M.2 SSD´s
    Storage #2Samsung 860 Evo 1TB SSD
    CPU CoolerArtic eSports 34 (Push/Pull) with P120 Fans
    CaseZalman P9 USB3 Midi Tower
    Power SupplyASUS ROG Thor 850W
    Keyboard ASUS ROG Strix Flare
    Mouse ASUS ROG Gladius II Origin
    Headset ASUS ROG Delta
    Mouse Pad BMW Motorsport
    Headset/Speakers Logitech Z623 2.1
    OS Win10 Pro 64x
    Network RouterFritz!
    Accessory #1 Corsair LL120/140 RGB Fan Kit
    Accessory #2 2x ASUS ROG LED Strip
    Accessory #3 ASUS ROG Throne Qi
    Shadow530's Avatar
    Join Date
    Nov 2018

    as i mentioned in the old thread...

    already V3.00.16 installed and same problem

    Computer Specs see in my profile

    Massive Problem:

    Armoury II ROG STRIX Menü

    when i want to set different static colors (customize menü, add 2 or more "effects") to my keys, the software freezes and crashes.

    when i want to change STRIX settings after this its freezes and crashes every time again

    must reset the whole keyboard settings then (FN + ESC for 10 secs)

    latest updates have been installed. still same problem.

  3. #3
    ROG Member Array Djordje PC Specs
    Djordje PC Specs
    MotherboardASUS ROG STRIX Z270E
    ProcessorIntel Core i5 7600k
    Memory (part number)HyperX Predator DDR4 RGB HX432C16PB3AK2/16
    Graphics Card #1ROG Strix GeForce GTX 1080
    MonitorAsus ROG PG279Q
    Storage #1Samsung EVO 960 256GB RAID 0 x2 512MB
    Storage #2Samsung EVO 860 512MB RAID 0 x2 1TB
    CPU CoolerROG Ryujin 240
    CasePhanteks ECLIPSE P350X
    Power SupplyCorsair HX Series 80PLUS Platinum
    Keyboard ROG Claymore Core
    Mouse ROG Gladius
    Headset HyperX Cloud Flight
    Mouse Pad ROG Scabbard
    OS Windows 10 Pro
    Djordje's Avatar
    Join Date
    Apr 2018

    I have Gladius mouse and whenever I go to calibration it's set to ROG Whetstone. Even when I switch off totally surface calibration it takes just to switch between tabs in armory software and surface calibration been restarted to ROG Whetstone.

    Is there any chance to add preset for ROG SCABBARD mousepad?
    Last edited by Djordje; 01-14-2019 at 08:47 AM.

  4. #4
    New ROGer Array
    Join Date
    Jan 2019


    It is impossible to assign a left button, what to do about it?
    Miniatura de Adjuntos Miniatura de Adjuntos Буфер обмена02333.jpg  

  5. #5
    New ROGer Array
    Join Date
    Jan 2019

    Armoury does not open.

    When I try to start Armoury I get a fault message something like "Please see to that all ROG devises are disconnected from Aura befor launching Armoury."
    I have no program called Aura installed.
    This means that I can't configure my asus mouse or keyboard.
    Please help!

  6. #6
    ROG Member Array
    Join Date
    Nov 2013

    Look for an off-topic or maybe ONtoppic ideea: MOVE THE MAGNUS SOFTWARE IN ARMORY... why you put me to control my microphone from another useless software when his place is in Armory ?

    thanks for rading this... i know for sure it will no be interesting for you*

  7. #7
    ROG Member Array blind1337nedm PC Specs
    blind1337nedm PC Specs
    Laptop (Model)Precision M4500
    MotherboardMSI 990fxaGD-65
    Memory (part number)Mix
    Graphics Card #11050ti(4gb)
    Graphics Card #2750ti(1gb)
    Sound Cardasus Xonar DG
    Storage #1SSD
    Storage #2HDD
    CPU CoolerDeepcool Captain 240
    CaseCorsair Spec 02
    Power SupplyEVGA 500 W
    Keyboard ROG Strix Flare
    Mouse Utechsmart Venus
    Mouse Pad Woven
    Headset/Speakers LOGITECH Z506
    OS Windows 10 x64
    Accessory #1 Joystick
    Accessory #2 Throttle Quadrant
    Accessory #3 Xk-24 keypad
    blind1337nedm's Avatar
    Join Date
    Jan 2019

    Hello, my keyboard (ROG Strix Flare) and armoury stops working when i add more than 3 effects (just static) and now i cant open armoury anymore- it freezes and keeps reconnecting the keyboard.
    I'm using the latest version of armoury (3.00.16)
    and ive updated to the latest firmware (0.00.35)

  8. #8
    ROG Guru: White Belt Array 28BeersLater PC Specs
    28BeersLater PC Specs
    MotherboardRampage V Extreme
    Graphics Card #1ROG Strix Vega 64
    Sound CardBose External USB
    MonitorLG IPS235 x3
    Storage #1Kingston HyperX Predator 480GB
    Storage #2Corsair Neutron XT Series 960GB
    CPU CoolerEK RVE Monoblock
    CaseCorsair 900D
    Power SupplyCorsair AX1200
    Keyboard Logitech K800
    Mouse ROG Spatha
    Headset/Speakers Bose Companion 5
    OS Windows 10 Pro
    Network RouterROG Rapture GT-AC5300

    Join Date
    Jun 2016

    I upgraded to this on Sunday, So Far Armoury itself seems ok, but with it I got the firmware update for my ROG Spatha.

    Currently running:
    Mouse Firmware 1.72
    Dock firmware 1.32

    I'm having serious issues with the mouse and dock needing repairing, - it looks like it is whenever the mouse goes to sleep, the light on the doc goes off and the mouse needs repairing.

    Unplugging and re plugging in the dock makes no difference, the fix process is to press the pairing light on the dock, then cycle the power on the mouse. (note pressing the dock pairing button then the mouse pairing button does not work)

    This is a real issue for me as I work from home, and every time I leave the mouse for a minute or so, I need to re-pair. I suppose I could bump up the "sleep" time (not checked if this fixes yet, just speculation) but as it is the battery barely lasts a day anyway. (how long should it last? I know there was a firmware issue before that drained it totally, maybe that's shortened its life).

    Whilst typing this, the mouse has shut down again and needs re-pairing!

    Win 10 Pro x64
    Rampage V Extreme
    Gotterdammerung: Rampage V Extreme | Intel I7-5930K | 32GB Corsair Dominator 2666 | EVGA GTX 980 SC x3
    Kingston HyperX Predator 480GB | Corsair Neutron XT 960GB | Corsair AX1200 | Corsair 900D | EK RVE Monoblock | EK 980 GTX Blocks

    GOOSE: STRIX Z390I Gaming | Intel i9-9900KF | 32GB Vengeance RGB 3200 | STRIX Vega 64 | Samsung 970 EVO Plus 1TB x2
    Corsair SF 750 | Phanteks Evolv Shift X | EK Z390I Monoblock | EK Strix Vega 64 GPU Block

  9. #9
    New ROGer Array
    Join Date
    Jan 2019

    Armoury II seems to slow things down

    Not sure if this is just affecting me but I have noticed a couple of issues with having the ROG Armoury II v3.00.16 software installed on my system.
    I have just bought a new ROG Claymore keyboard and installed ROG Armoury II. I noticed that my system was not as snappy as it was the day before, things seemed to be a little slower since installing it.
    When opening Internet Explorer it takes a while before my homepage (google) is displayed.
    And my Eaton UPS Companion software fails to start on boot up.
    As soon as I uninstall ROG Armoury II and reboot, My whole system is back to normal.
    I have tried to uninstall and reinstall and reboot but the same behaviour returns.
    Seems quite odd.

    This is the first time for me using ROG Armoury

    My System Specs are:

    MB: ASUS ROG Strix X470-F Gaming
    RAM: G.Skill Trident Z RGB 3200mhz (DOCP)
    CPU: AMD Ryzen 7 2700X
    SSD: Samsung 970 EVO 500GB
    Keyboard: ASUS ROG Claymore
    OS: Windows 10 x64 version 1809
    Last edited by brendenl; 01-17-2019 at 10:20 AM.

  10. #10
    ROG Member Array
    Join Date
    Oct 2018

    Angry The app is poorly written for such expensive devices

    Every time I open this app it crashes, see the following log:

    it only works once after installation, then either the application disappears from windows or crashes when I open it.

    Application: ROG Armoury.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.ComponentModel.Win32Exception
    at System.Diagnostics.Process.Kill()
    at ROG_Armoury_III.MainWindow.Window_Loaded(System.Ob ject, System.Windows.RoutedEventArgs)
    at System.Windows.RoutedEventHandlerInfo.InvokeHandle r(System.Object, System.Windows.RoutedEventArgs)
    at System.Windows.EventRoute.InvokeHandlersImpl(Syste m.Object, System.Windows.RoutedEventArgs, Boolean)
    at System.Windows.UIElement.RaiseEventImpl(System.Win dows.DependencyObject, System.Windows.RoutedEventArgs)
    at System.Windows.UIElement.RaiseEvent(System.Windows .RoutedEventArgs)
    at System.Windows.BroadcastEventHelper.BroadcastEvent (System.Windows.DependencyObject, System.Windows.RoutedEvent)
    at System.Windows.BroadcastEventHelper.BroadcastLoade dEvent(System.Object)
    at MS.Internal.LoadedOrUnloadedOperation.DoWork()
    at System.Windows.Media.MediaContext.FireLoadedPendin gCallbacks()
    at System.Windows.Media.MediaContext.FireInvokeOnRend erCallbacks()
    at System.Windows.Media.MediaContext.RenderMessageHan dlerCore(System.Object)
    at System.Windows.Media.MediaContext.RenderMessageHan dler(System.Object)
    at System.Windows.Media.MediaContext.Resize(System.Wi ndows.Media.ICompositionTarget)
    at System.Windows.Interop.HwndTarget.OnResize()
    at System.Windows.Interop.HwndTarget.HandleMessage(MS .Internal.Interop.WindowMessage, IntPtr, IntPtr)
    at System.Windows.Interop.HwndSource.HwndTargetFilter Message(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
    at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
    at MS.Win32.HwndSubclass.DispatcherCallbackOperation( System.Object)
    at System.Windows.Threading.ExceptionWrapper.Internal RealCall(System.Delegate, System.Object, Int32)
    at System.Windows.Threading.ExceptionWrapper.TryCatch When(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
    at System.Windows.Threading.Dispatcher.LegacyInvokeIm pl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
    at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)

    ================================================== =====================

    Faulting application name: ROG Armoury.exe, version:, time stamp: 0x5bdff3f1
    Faulting module name: KERNELBASE.dll, version: 10.0.17134.441, time stamp: 0x3da51fd0
    Exception code: 0xc000041d
    Fault offset: 0x00111812
    Faulting process id: 0x35c
    Faulting application start time: 0x01d4aea8a4a188ac
    Faulting application path: C:\Program Files (x86)\ASUS\ROG Armoury\ROG Armoury.exe
    Faulting module path: C:\Windows\System32\KERNELBASE.dll
    Report Id: 150b445e-a370-4ed2-b211-4e850f14c1e3

    ================================================== =====================

    Application: MacroAgent.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NullReferenceException
    at Claymore.Protocol+<>c__DisplayClass2.<InterruptTra nsfer_Read_CBFunc>b__0(System.Object)
    at System.Threading.QueueUserWorkItemCallback.WaitCal lback_Context(System.Object)
    at System.Threading.ExecutionContext.RunInternal(Syst em.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.ExecutionContext.Run(System.Threa ding.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.QueueUserWorkItemCallback.System. Threading.IThreadPoolWorkItem.ExecuteWorkItem()
    at System.Threading.ThreadPoolWorkQueue.Dispatch()
    at System.Threading._ThreadPoolWaitCallback.PerformWa itCallback()

    ================================================== =========================
    Faulting application name: MacroAgent.exe, version:, time stamp: 0x5bdff403
    Faulting module name: unknown, version:, time stamp: 0x00000000
    Exception code: 0xc0000005
    Fault offset: 0x06ca650a
    Faulting process id: 0x528
    Faulting application start time: 0x01d4aea7f405d547
    Faulting application path: C:\Program Files (x86)\ASUS\ROG Armoury\MacroAgent.exe

Page 1 of 18 1 2 3 11 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts