Results 1 to 7 of 7

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Jul 2018

    GL702VM Won't POST

    My laptop ROG STRIX GL702VM won't POST. Screen is black, with no ROG logo splash screen. LED indicator light for battery (charging) and power works, but the storage LED doesn't blink even once. I tried removing battery and CMOS battery with no luck. Is there another way to reset BIOS CMOS?

    I tried holding power button for 2 minutes again no luck. I tried removing both RAM modules and it gives flashing green LED indicator. Tried one of either RAM gives no flashing green LED, but still won't POST. I also tried swapping NVMe and HDD for boot drives and also Windows 10 bootable USB, but it doesn't look useful, since it won't even load the UEFI BIOS. The CPU fan is active, and all the USB ports output power, however the keyboard is off (Backlight is off and CapsLock does not toggle). I tried plugging external USB keyboard, but it isn't detected.

    I'm out of ideas. I called Customer Service for repair cost, he quoted $600 USD. That's insane! If anyone ever solved this problem, please let me know.
    Last edited by ReptillusMax; 01-15-2019 at 02:56 AM. Reason: Updated troubleshooting attempts.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts