Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    3

    Exclamation Z390 I- Gaming having lots of problems Really need Help please.

    Hello,

    I have purchased a Z390 I-Gaming mobo.

    I'm having huge difficulty's with a lot of stuff I am stuck for more then 2 days now trying to solve all these issues and I really need help to get it to work because I am completely lost at the moment and pretty frustrated.
    I want to access my bios so I can change bootorder to boot from usb and do a secure erase on my ssd and install Win 10 again.
    I want to select XMP profile for my ram & later overclock my cpu.
    I want to update my bios to the latest version.

    Whatever I do I cannot enter my bios, in the manual it says I need to press F2 or del before post but this doesn't work. There is no message that pops up and i go straight to windows login screen. I've tried connecting different monitors now currently using one with dvid-d because my other monitor only has DP and HDMI. I have tried connecting different keyboards because appearantly *my Corsair K70 keyboard wont allow going to bios. I'm using a gigabyte GK-K7100 atm.

    My bios is in legacy mode appearantly according to windows. When I try to go to settings in windows startup > Update and security > recovery> advanced startup there is no option to boot fromUEFI because I am in legacy mode.*

    I've tried downloading Ai suite 3 there are multiple options to update bios one of them is ez update whatever I do i keep on version0401. There is an option ton manually update bios under EZ update tab in Ai suite 3 I've downloaded the driver from Asus drivers and tools section on their website and choose the file manually this doesnt work either it restarts my pc and goes trough installation but nothings updated.

    Is there an option to select XMP profile with some Asus software running in windows or do you really need to go into your bios during startup?

    If someone could help me out it would be greatly appreciated guys.*

    EDIT: I've read in my manual that ''when downloading *or updating the BIOS file, rename it as RSZ390IG.CAP for this motherboard, I want to try this but my pc won't boot anymore.

    I've tried clearing CMOS RTC RAM Data *by short circuit pin 1-2 with a jumper cap for about 5-10 seconds but now when I restart my pc the QLED stays lit at bright white and nothing is happening anymore only a black screen on my monitor And I really don't know what to do anymore now. Now I have a problem with my BOOT VGA DRAM or CPU according to the manual.
    Last edited by Iniura; 01-19-2019 at 06:23 PM.

  2. #2
    ROG Guru: Yellow Belt Array x-rated PC Specs
    x-rated PC Specs
    MotherboardAsus ROG Maximus XI Formula - Intel Z390
    ProcessorIntel Core i9-9900K @ 5 GHz
    Memory (part number)G.Skill Trident Z F4-3600C16D-16GTZR - 4x 8 GB, 4 GHz, 18-18-18-38
    Graphics Card #1Nvidia GeForce RTX 2080 Ti FE - 2,1/15,6 GHz
    Sound CardCreative Sound Blaster X-Fi Titanium HD
    MonitorDell UP2715K - 5120x2880, AH-IPS, 10bit
    Storage #1Sabrent Rocket - 4 TB, 3 GB/s
    CaseFractal Design Define R6 Blackout TG
    Power SupplyCorsair HX1000i - 1 KW, 83 A, 80Plus Platinum
    Keyboard Logitech G810 Orion Spectrum
    Mouse Logitech G403 Prodigy Wired
    Headset Sennheiser HD 660 S
    Mouse Pad Razer Manticor
    OS Windows 10 Pro
    Network RouterHuawei HG8245H @ 1 Gb/s FTTH GPON
    Accessory #1 EKWB Velocity + Vector
    Accessory #2 EKWB XRES 140 Revo D5 PWM + 2x CoolStream XE 360
    Accessory #3 6x Noiseblocker NB-eLoop Fan B12-PS
    x-rated's Avatar
    Join Date
    Aug 2015
    Reputation
    11
    Posts
    203

    try this:
    1) turn off pc
    2) disconnect keyboard
    3) turn on pc (no keyboard connected error should appear)
    4) connect keyboard and try to enter bios

    probably you have to recover the bios first, so follow the steps in manual for bios flashback
    Last edited by x-rated; 01-19-2019 at 06:30 PM.

  3. #3
    ROG Junior Member Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    3

    I am going to try that ty. Appearently the vga Qled stays white at the moment. And it is stuck on black screen.

    Edit: It doesnt work screen stays blac, i've tried attaching my other screen again trough DP and HDMI same issue. Mann I cannot explain how frustrating this new build has been I am sick of it. Maybe removing CMOS battery help but I cannot find the damn thing it's underneath my heatsink on my mobo I think and for that to get off I have to remove my PSU and sttuff dammit.*

    I will try to flash back my bios using ASUS crash free Bios 3, I hope my pc will detect the bios file on a usb stick. I think you mean that by bios flashback.*
    Last edited by Iniura; 01-19-2019 at 07:33 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •