Page 3 of 3 FirstFirst 1 2 3
Results 21 to 26 of 26
  1. #21
    ROG Member Array
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    6

    Quote Originally Posted by DaLumberJack View Post
    Yep and there has been no not fix update or any other firmware release since the last one.

    Again, I would of returned this router if I was within the 30 day return window.

    I think by far, this product release and more specifically the after release support has been the worst for Asus. All they are doing is making their brand credibility go down.
    hmm new firmware ? 3.0.0.4.384_5979

  2. #22
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    11

    Damn, was thinking from going from GT-AC5300 (which has been pretty horrible...) to this one, but I guess I will just go with the new Netgear instead. Very disappointing that they are screwing up this model as well.

  3. #23
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    5

    Quote Originally Posted by bogdi1988 View Post
    Damn, was thinking from going from GT-AC5300 (which has been pretty horrible...) to this one, but I guess I will just go with the new Netgear instead. Very disappointing that they are screwing up this model as well.
    I had the latest and best AX from netgear, its terrible. The gui and OS is old. Its stripped down OS is the worst. I have the GT-AX11000 and I will proudly take that any day over Netgear junk. My GT-AX11000 has been solid after the first update. I had them both side by side and I hated everyday with the Netgear. I am so glad I returned it.
    Last edited by MadHatter01; 05-15-2019 at 04:15 PM.

  4. #24
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    11

    Quote Originally Posted by MadHatter01 View Post
    I had the latest and best AX from netgear, its terrible. The gui and OS is old. Its stripped down OS is the worst. I have the GT-AX11000 and I will proudly take that any day over Netgear junk. My GT-AX11000 has been solid after the first update. I had them both side by side and I hated everyday with the Netgear. I am so glad I returned it.
    So you're pretty much saying that no one is really making a good solid router anymore. If Netgear is as bad as you say and you'd pick the GT-AX11000 over that, then there's nothing good on the market... I was thinking of the RAX200.

  5. #25
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    5

    Quote Originally Posted by bogdi1988 View Post
    So you're pretty much saying that no one is really making a good solid router anymore. If Netgear is as bad as you say and you'd pick the GT-AX11000 over that, then there's nothing good on the market... I was thinking of the RAX200.
    Netgear has DumaOS istcould of used and that OS is really good. They picked their stock junk os because they will wait 6-12 month and release the exact same router for more money with DumaOS on it. Honestly if it came with DumaOS I would of kept it. If you like power features then Netgear is a no go right now. The hardware is really good, just the OS was the issue.

    I had the RAX120 and it is the same OS. Also the RAX200 cost way more then the GT-AX11000 for the same hardware.
    Last edited by MadHatter01; 05-16-2019 at 06:43 PM.

  6. #26
    ROG Enthusiast Array
    Join Date
    Jul 2012
    Reputation
    10
    Posts
    26

    I sent an email to Asus saying that IPV6 was not working. They sent me an email with a link to a beta version firmware file. Version GT-AX11000_9.0.0.4_384_6156-g5ade871_cferom_ubi. I can confirm that my IPV6 is working now.

    Here is the link they sent me.

    https://www.asuswebstorage.com/navig...27D35802D28EEY

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •