Results 1 to 3 of 3
  1. #1
    New ROGer Array alfsabando's Avatar
    Join Date
    Jan 2019

    ARMOURY CRATE not working

    I recently installed the ARMOURY CRATE app from the windows store and for some reason it didn't recognize my laptop's serial number. It did say that it's in beta but it did recognize my mouse and headset so I'm not sure.

  2. #2
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011

    For the moment. Crate only works on Z390 ROG as far is my understanding.
    Learn, Play Enjoy!

  3. #3
    ROG Enthusiast Array AliAPCMR PC Specs
    AliAPCMR PC Specs
    MotherboardZ390 E
    Processori5 9600k
    Memory (part number)Corsair RGB Vengeance (Corsair CMR16GX4M2A2666C16)
    Graphics Card #1GTX 1070 EVGA FTW
    Sound CardAsus SupremeFX
    MonitorSamsung 1080p 40inch 3D Tv
    Storage #1Samsung Evo 500gb SSD
    Storage #23TB & 2TB &500GB HDD
    CPU CoolerNoctua U12S
    CaseNZXT Noctis 450
    Power Supply850 wats EVGA SUPERNOVA
    Keyboard Corsair Raptor K30
    Mouse Logitec M305
    Headset Creative Sound Blasters Rage V2 Wireless (RGB)
    OS Windows 10 (Latest Update)
    Accessory #1 NZXT GRID V2
    Accessory #2 NZXT HUE PLUS
    AliAPCMR's Avatar
    Join Date
    Sep 2017

    Hey guys I am having a issue a brand new build with a z390 H and a i5 9600k OS installed and when i boot into windows i get a prompt to download Armoury Crate and when i download it and run it, it provides me with a few software updates which when i try to install they always get stuck on 55% i have re installed the OS and i have installed all windows updates and installed the latest bios version and its still the same. Also when I run Crate it only gives me two options Highlights and Tools, None of the other advertised options are avaiable on the drop menu this is a brand new build no idea what the issue is here. I have uploaded a image to.

    Thanks for your help
    Miniatura de Adjuntos Miniatura de Adjuntos Asus issue.jpg  

    Last edited by AliAPCMR; 05-06-2019 at 09:54 PM. Reason: More Info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts