Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Feb 2019

    2xNvidia Titan on Rampage 4 Formula -- 2nd GPU is not detected

    I will have to re-post what I think are crucial parts from discussion on another forum. For complete discussion, I refer you to here:

    PCI lanes are numbered according to the user manual
    Click image for larger version. 

Name:	GBOCbKF.jpg 
Views:	1 
Size:	92.4 KB 
ID:	78788


    It's a 5-year old rig. The specifications are as follows:
    CPU: 12-core i7-3930k
    Motherboard: Rampage 4 Formula
    2xGPU: NVidia gk110 Titan 6GB
    RAM: Corsair 32GB

    First, may be it's important, I don't know... The rig has been used for scientific computations, not for gaming -- so people who use it decided that GPUs don't need to be SLI-ed. Is it a mistake or not? I don't mean performance-wise, I mean is it necessary to have GPUs SLI-ed for them to be even detected by a PC?

    Now to the main question. This is how it was when I was asked to look what might be the problem... The motherboard has 4 PCI lanes. They are all on. GPU#1 is on PCI#1, GPU#2 is on PCI#4. The display is connected to GPU#1 through DVI. Both GPUs are powered up -- their lights are on, their fans work. But GPU#2 is not detected -- neither in the OS (Ubuntu), nor in the BIOS. During start-up, motherboard beeps as if everything was normal though.

    First thing I did was connect the display to GPU#2. It didn't turn on during startup. Then I switched PCI lanes -- put GPU#2 on PCI#1 and GPU#1 on PCI#4. The display is still on faulty GPU#2 -- and it doesn't turn on on startup. Then I re-connected the display to GPU#1 (which is now on PCI#4) -- and everything worked fine.

    Naturally, I decided GPU#2 was dead and left, leaving faulty GPU#2 on PCI#1 and GPU#1 on PCI#4. Before leaving, I restarted the computer several times to see how it would be booting up, now that GPUs had changed lanes... Everything was fine.

    I was phoned later that day, told that now display didn't turn on even when connected to a working GPU#1. I went back and restored everything to the original setting -- put GPU#1 back on PCI#1 and GPU#2 on PCI#4. Now everything works fine again, but it got me thinking whether presumably faulty GPU#2 is really faulty, if I somehow managed to make GPU#1 fail to work properly when changed lanes.


    what I did yesterday, when I had a chance to examine the rig once more. Took working GPU#1 out, plugged what I thought was faulty GPU#2 into PCI#4 (16x/8x). At first, the display didn't turn on during startup. But then I plugged the display into the 2nd DVI-port on GPU#2 -- this way it worked. So either GPU#2 is not completely dead or it's not dead at all, and something else is wrong.

    Next, I plugged GPU#1 into the PCI#1 (16x). At this point GPU#2 is still on PCI#4 and the display is still connected to it. The display did turn on, but GPU#1 on PCI#1 is not detected in BIOS. So I put GPU#1 into PCI#2, which is 8x -- still nothing, BIOS doesn't see it. Then I found PCI Lane Simulator in BIOS and marked PCI#2 and PCI#4 as explicitly occupied. And voila -- GPU#1 on PCI#2 is now detected in BIOS too, and I have 2 GPUs.

    Only problem is they are both on 8x now (PCI#4 which is occupied by GPU#2 at this point is 16x/8x,but it automatically converted to 8x, once the GPU#1 on PCI#2 was finally detected). Encouraged, I put GPU#1 back into PCI#1 (which is 16x) and tried to play with Lane Simulator in BIOS once again. Nothing! GPU#1 is not being detected once again!

    I believe it's safe to assume at this point that the problem lies not with the GPUs, but with the motherboard. User's manual for Rampage 4 Formula suggests that one can run two GPUs on 16x in slots #1 and #4.


    Yesterday I tried every configuration imaginable.

    I found the rig with GPU#1 on PCI#4 (which is what the display was connected to) and GPU#2 on PCI#1 (not detected) -- this is a working configuration, in a sense that the display does turn on. So I pulled GPU#2 out of PCI#1, leaving GPU#1 on PCI#4 -- it worked. Then I pulled GPU#1 out of PCI#4 and put GPU#2 into PCI#1 -- didn't work. Then I inserted GPU#1 into PCI#1 instead of GPU#2 -- didn't work either!!!

    I had to fall back on the initial working configuration, plugging GPU#1 back into PCI#4. Without GPU#2 being plugged into PCI#1 it didn't work as well -- I had to plug GPU#2 into PCI#1 even though it's not detected in BIOS. Then I played with the lane simulator, telling it there's nothing on PCI#1, took GPU#2 out, and only then GPU#1 managed to turn the display on without GPU#2 being present.

    After that I tried putting GPU#2 into PCI#2 (GPU#1 is still on PCI#4 at this point) -- this is how I got it to recognize both cards (even though at 8x) several days ago. Told lane simulator that PCI#2 should be considered as occupied and restarted. The display did turn on, but BIOS didn't detect GPU#2 on PCI#2.

    After some more juggling with no meaningful results, I reverted it to the initial configuration and called it a day.

    This is very weird and frustrating... I don't see any patterns -- what works and what doesn't. It's like the motherboard gets stuck on the last working configuration. Sometimes it gets unstuck, as over the last week I have managed to get it to recognize several configurations (even the one with both cards detected, although at only 8x), but what exactly does that is escaping me...

    I guess at this point there's no avoiding updating the firmware, which as it is dates back to 2012, which I tried to avoid, lest I somehow bricked the motherboard.


    Before updating the firmware and everything, I thought I'd consult here first. Any ideas?
    Last edited by homeo.morphizm; 02-11-2019 at 07:59 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts