Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    10

    Gl504GM - Loud Fans and Fluctuating Sound Output

    Just bought my GL504GM last November and other than the problem I see here of the right speaker frequently dropping in volume (without any adjustment on my part) I've been enjoying gaming on it.

    Unfortunately recently I've noticed that the CPU Fans (the left side) has been acting really weird after the BIOS 307 update. I've been regularly updating using the MyASUS app and windows update but recently the fan has started to bother me and sounds like there's a plane that's ready to take off.

    Fan Control thru Gaming Center does nothing even when I set it on silent.

    I've noticed that there are several posts in the GL products forum about these issues. Has ASUS identified the problem already and are there solutions that may address this in the future (via driver update or otherwise)? This is my first personal Windows laptop in 8 years and in a few months these 2 problems, with the loud fan in 6000-7600rpm at idle being the biggest issue.

    Thanks in advance!

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    300
    Posts
    7,440

    Thread moved to GL section. Please do not post in Service Inquiries unless you have an existing RMA. Thank you.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Member Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    9

    Same issue

    Im having this exact same problem since 307 update. I've tried to roll back to 304 but even with 304 version the problem persists.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •