Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    8

    HDMI cable after 4 monts already broken ???

    hello all.
    i bouht my centurion nov 8 2018 and is now 4 old, and already the left cup, one of the cables inside of the HDMI is broken when i turn my head left or right.
    i notesed that this week when i playing a game and sound came only from the righr cup. but some speakers are still working in the left cup and need to do a speaker test to know witch one it is.
    to be sure it's the cable i move the cable by hand close to the cub and sound came back again and after reliecing the cable, sound stops in the left cup.

    realy guys .??? after 4 monts already !!????.
    this can happen after a few years if quality is around 50 dollars or less but a headset above 300 you chould ecspect some bette quality but i gues i was wrong !!


    this is not the firt head set i had in my life in the last 59 years most of the time never had a cable problem because i am very carefull on those thing just bcause music is my life so without a headset i will never be !

    so my question is: the warrenty also involve the calbe ?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600
    Memory (part number)16GB DDR4
    Graphics Card #1GTX980
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    294
    Posts
    7,346

    Contact customer service and see if they will setup an RMA. Can't hurt to try.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Member Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    8

    Angry

    Quote Originally Posted by xeromist View Post
    Contact customer service and see if they will setup an RMA. Can't hurt to try.
    oke i am back again after returning it to to shop and they gave me a hole new one.. is't that great !!

    but now after using 1 month (and notes it from the start) that sometines when i turned my head to the right i heart a tick sound . and sound was disable and came back again if i turned my head straight again.
    ad first didden't give it a though because was not that often. bu one time i put the headset bside me on the table and had to lift up the cable and notes tha the unit want out... W T FXXXX ???? AGAIN BROKEN !?!?!?!? M F....XXX!!!
    sorry fo my word but that how i am PISTE OFF RIGHT NOW !!!!!!

    NOW i am gone return it and DEMAND my money back !!!!

    cables are realy JUNK / CHIT/ XXXX to me now and lost my confidence in tis JUNK of an HEADSET !!!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •