Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    2

    Gaming Centre showing wrong GPU information

    Hope this is the right thread for this.

    I'm having issues with my gaming centre, I've tried searching to see if anyone else has this problem but I've only seen other people with CPU information being wrong.

    The GPU information is showing the wrong speed and temperature and I was hoping someone knows why and how to correct it? When I first bought the laptop it was working fine, it's only 5 months old.

    Thanks.
    Miniatura de Adjuntos Miniatura de Adjuntos ROG Centre.jpg  


  2. #2
    New ROGer Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    2

    Quote Originally Posted by MoKiChU View Post
    Hi,

    Do you use the latest version 2.5.10 of ROG Gaming Center : https://dlcdnets.asus.com/pub/ASUS/G...0_64_V2510.zip ?
    I'm not sure how to find out what version I am using, so I uninstalled it and reinstalled it from that link, now it doesn't show any information for my CPU but shows the exact same information for the GPU.

  3. #3
    ROG Member Array jocok's Avatar
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    10

    Hi , not the version of the graphic card is bugged. (or the thermal paste or your laptop)
    The problem is the newest nVidia Graphic Card driver! Make sure you're set your nVidia Card to default.
    Step 1; nVidai control panel - Open the Nvidia Control Panel. You can do this by right-clicking on the desktop or you can find the option within the notification area of the Taskbar.
    Step 2; Select Manage 3D Settings under 3D Settings.
    Step 3; Now select the 'preferred graphics processor' in the drop down list (you can see what the automatic option is listed as global setting). If you want to use the dedicated graphics card, select High-performance Nvidia processor. - This is the Important to select Dedicated nVidia Graphic card to your setting!

  4. #4
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    1

    Quote Originally Posted by jocok View Post
    Hi , not the version of the graphic card is bugged. (or the thermal paste or your laptop)
    The problem is the newest nVidia Graphic Card driver! Make sure you're set your nVidia Card to default.
    Step 1; nVidai control panel - Open the Nvidia Control Panel. You can do this by right-clicking on the desktop or you can find the option within the notification area of the Taskbar.
    Step 2; Select Manage 3D Settings under 3D Settings.
    Step 3; Now select the 'preferred graphics processor' in the drop down list (you can see what the automatic option is listed as global setting). If you want to use the dedicated graphics card, select High-performance Nvidia processor. - This is the Important to select Dedicated nVidia Graphic card to your setting!
    I had the same issue after updating the graphics card driver. This worked! Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •