Results 1 to 2 of 2
  1. #1
    New ROGer Array tap002 PC Specs
    tap002 PC Specs
    Laptop (Model)ROG Strix GL703GE-IS74
    MotherboardASUSTeK COMPUTER INC. GL703GE
    Processori7-8750H CPU @ 2.20GHz
    Memory (part number)16GB DDR4 2666MHz DRAM
    Graphics Card #1GTX 1050i
    Storage #1MICRON 1100_MTFDDAV256TBN
    tap002's Avatar
    Join Date
    May 2018
    Reputation
    12
    Posts
    107

    ROG Gaming Center GL703GE

    After NVIDIA 418 driver update and latest windows updates Gaming Center will open for 1 second then close. If I uninstall then reinstall it will work until I shut down or restart. Repair does not work. If I change settings right after reinstall it remembers the settings. ROG Gaming Center Service is running.

  2. #2
    New ROGer Array tap002 PC Specs
    tap002 PC Specs
    Laptop (Model)ROG Strix GL703GE-IS74
    MotherboardASUSTeK COMPUTER INC. GL703GE
    Processori7-8750H CPU @ 2.20GHz
    Memory (part number)16GB DDR4 2666MHz DRAM
    Graphics Card #1GTX 1050i
    Storage #1MICRON 1100_MTFDDAV256TBN
    tap002's Avatar
    Join Date
    May 2018
    Reputation
    12
    Posts
    107

    Discovered that stopping the ROGGamingCenterService allows me to launch gaming center without crashing or closing. As soon as I launch gaming center the service starts. For some reason ROGGamingCenterService running at boot up prevents gaming center from opening??? Once launched, I can open or close as long as I don't restart or shutdown. Gaming center installs two services; ROGGamingCenterService and Intel(R) Extreme Tuning Utility service. By default gaming center runs automatically and Intel runs auto delayed. I set gaming service to manual, I can start gaming center and the services starts, problem solved. BUT, I run as standard user. When I log out of administrator account log in as standard user the gaming "service" does not start even though I launch gaming center as administrator (chicka boom, chicka boom don't ya just love it). Gaming center opens but doesn't read temp or MHz because the service does not start. Any brilliant minds out there have a theory as to why the service running at boot up prevents gaming center from staying open on initial launch???

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •