Results 1 to 10 of 10
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    36

    GX501GI 10.1.2.306 Firmware update?

    Windows 10 update is showing me a firmware update (10.1.2.306) for the GX501GI which I have. There is no information about it anywhere but I'm assuming it is a bios update - am currently running 304 which is what the Asus support website shows. I paused my windows updates as I don't like updating a firmware / bios if there is no information about it.

    Not sure why this update is now showing as the date on it seems to be from months ago either.

    Has anyone installed this 10.1.2.306 firmware update on a GX501GI?

  2. #2
    ROG Enthusiast Array FixGX501G's Avatar
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    27

    I've got GX501GI too, but there no 306 BIOS available for me yet, neither via windows nor via ASUS live update.

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    36

    Quote Originally Posted by FixGX501G View Post
    I've got GX501GI too, but there no 306 BIOS available for me yet, neither via windows nor via ASUS live update.
    Interesting - I was on 304 but had no choice of bypassing 306 since it was blocking all other windows updates. 306 bios update went through but I have lost all audio on my laptop now - tried reinstalling Audio driver from the Asus website but same deal. Still investigating and will report when I get my audio back. Sighs

    UPDATE: Ok so I got it fixed by going into the (useless) bios and force a save then exit reboot and voila the audio is back - I had restarted and reinstalled audio drivers like 5 times and no audio would work until I did this. I have to say the ROG bios for this laptop doesn't offer much when it comes to tweaking it - pretty disappointing. Will report if I see instabilities in the system - I havent found any info about bios 306 for the GI
    Last edited by Pheebau; 02-27-2019 at 11:40 PM.

  4. #4
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    1

    I can confirm with the above poster that after updating GX501GI to 306 BIOS through Windows Update, the audio will no longer work. What fixed it for me was downgrading the BIOS in Winflash, and then Windows update immediately forced it to 306 again. The second flash worked fine and has seemed normal for the past week. Is there any release notes for this BIOS? It's not even shown on the ASUS download/support website.

  5. #5
    ROG Enthusiast Array FixGX501G's Avatar
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    27

    A couple of weeks ago asus sw flashed 306 also on my GX501GI. It did it in the Background without notifying me and nothing. In the middle of a gaming session it just sayed "your PC will be now restarted due to BIOS update" and immediately did reboot. That installation policy felt more like a virus than a part of ASUS sw. I was not even asked if I want to start the flashing procedure. Probabaly because it was an automatic update procedure via Windows Update. However problems started to sum up after the update. I decided to run Windows recovery to have a fresh OS installed. That broke up in the middle of the process and I tried literally everything to perform the recovery, but it just did not want to. So I decided to create a bootable recue disk... that was a big mistake. The recovery from the disk broke up, too... but it removed all data on C. Also the recovery Partition by ASUS. Now the machine went to ASUS Service for a fix.

  6. #6
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    4

    I've upgraded to 306 and so far no issues. Much like FixGX501G I was in the middle of something and all of a sudden my BIOS is reflashing! I wondered what the heck I did wrong, but I guess that's how it's done now. My audio is still working fine, as is everything else. Let's hope it stays that way.

  7. #7
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    36

    Ok good to know am not the only one

    System has been stable so far

    I thought it was a virus for a moment especially given the trojan via Asus live update trojan report I found today but luckily am not affected so it sounds 306 was legit.

    https://rog.asus.com/forum/showthrea...n-ShadowHammer

  8. #8
    ROG Enthusiast Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    36

    You guys should disable auto-install of updates in Windows. In my case, this was one of the first thing I did when I got the machine and I can then decide when to install updates by priory checking - no auto-install of bios, etc

  9. #9
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    3

    GeForce perf limiter bug fixed

    This fixed a massive bug for me that caused the GeForce perf limiter to get stuck on power mode instead of utilization after waking up from standby. They installed it before it showed up on the website when my laptop was in for an RMA. It may be unrelated but now I'm unable to change my fan mode though. Just glad I can finally game without horrible frame rate.

  10. #10
    ROG Enthusiast Array FixGX501G's Avatar
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    27

    I've got back my machine today.

    BIOS version is 306. It als shows up for download at the ASUS download center für GX501GI now.

    ASUS rep team stated that this machine was not affected by ShadowHammer. I've got a different feeling though, but whatever. Updated the LiveUpdate tool to 3.6.8.

    Now I've got a set back to factory defaults GX501GI and it seems like the "after sleep gtx1080 mem stuck at 200 in low power mode with temp and power cap" issue is gone.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •