Results 1 to 9 of 9
  1. #1
    ROG Member Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    9

    Disable G751 Trackpad When Mouse is Attached?

    I am running Windows 7 64-bit on the ASUS G751. I almost always use a USB mouse. How do I disable the trackpad when a mouse is attached? I installed a Synaptics driver that added this option to the Mouse in Control Panel, but checking this checkbox did not disable the trackpad.

    Is there another solution?

    Thanks for any and all advice.

  2. #2
    ROG NEWBIE Array mintys1's Avatar
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    44

    Quote Originally Posted by Technomann2 View Post
    I am running Windows 7 64-bit on the ASUS G751. I almost always use a USB mouse. How do I disable the trackpad when a mouse is attached? I installed a Synaptics driver that added this option to the Mouse in Control Panel, but checking this checkbox did not disable the trackpad.

    Is there another solution?

    Thanks for any and all advice.
    on the G752 you can use FN + F9 to disable it, don't know if its the same on your 751...
    G750 -JHA -32GB -256GB SSD -512GB SAMSUNG 840 PRO SSD
    Windows 8.1...Home Ed.
    Latest Kit..Sep 2016
    G752-VY-32GB- 2 X 256GB SSD'S + 512GB SAMSUNG 840 PRO Windows 10 Home Edition.

  3. #3
    ROG Member Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    9

    Quote Originally Posted by mintys1 View Post
    on the G752 you can use FN + F9 to disable it, don't know if its the same on your 751...
    Thanks but this key does not work on my machine. I installed ASUS Smart Gestures which has an option to disable the trackpad, but that only works some of the time!

    Why can't I disable the damn trackpad? It causes my text to go wonky when I am typing...

  4. #4
    ROG Guru: Brown Belt Array davemon50 PC Specs
    davemon50 PC Specs
    Laptop (Model)Asus G752VY-DH72 (17") and Asus G752VT-DH74 (17")
    MotherboardAsus ROG LGA2011-v3 Rampage V Edition 10, x99 EATX
    ProcessorIntel Core i7-6950X Extreme 10-core 25MB Cache 3.0 GHz
    Memory (part number)Corsair Vengeance LPX Red DDR4 DRAM 64GB-4x16 3333 (CMK64GX4M4B3333C16R)
    Graphics Card #1Sapphire Nitro Radeon R9 Fury 4GB HBM Backplate
    Graphics Card #2Sapphire Nitro Radeon R9 Fury 4GB HBM Backplate
    Sound CardAsus SupremeFX Hi-Fi Audio DAC
    Monitor(2) Dell UltraSharp U2515H 25-inch monitors
    Storage #1(3) SSD's - Samsung 960 1TB M.2, Intel 535 480G, Intel 510 250G
    Storage #2(3) HDD's - Western Digital Caviar Black 2TB 3.5-in SATA III 64MB Cache
    CPU CoolerCorsair Hydro Series H80
    CaseCorsair Obsidian Series 650D Black, ATX, Mid Tower
    Power SupplyCorsair Digital AXi-Series AX1200i (1200W) 80+ Platinum Rating
    Keyboard Logitech Wireless K360
    Mouse Logitech Wireless MX Anywhere 2
    Headset HyperX Cloud II
    OS Windows 10 Pro 64-Bit
    davemon50's Avatar
    Join Date
    Apr 2017
    Reputation
    45
    Posts
    1,002

    You might be a fat-finger (or lazy) typer like me. I use Smart Gesture and it does work, but I found myself re-activating the touchpad inadvertently on my own because my thumb knuckles would sometimes tap the touchpad a couple times while typing fast. That simulated the double finger tap and the touchpad would re-activate. If you go into Smart Gesture to the first tab (Gesture), you can UN-check the box that says "Activate" under the "One Finger" section. That way accidental double-taps do not override what you've set under the Mouse Detection tab.
    Davemon50

  5. #5
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    176

    u can deactivate this thing..in Bios..restart the notebook and press ESC & F1
    then go under Advance and there u can deactivate "Internal Pointing Device"
    Last edited by kingjezdi; 03-16-2019 at 11:25 AM.

  6. #6
    ROG Member Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    9

    Quote Originally Posted by kingjezdi View Post
    u can deactivate this thing..in Bios..restart the notebook and press ESC & F1
    then go under Advance and there u can deactivate "Internal Pointing Device"
    Yeah I already figured that one out - thank you. This is what I did as I am tired of dealing with this issue.

    Thanks to all who responded!

  7. #7
    ROG Member Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    17

    Probably not the same kind of ASUS bloatware in a G751 as in my G752, but I use the ROG Gaming Center app which allows you to disable the touchpad. This works and has continued to work for me.

  8. #8
    ROG Member Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    9

    Quote Originally Posted by azwxguy View Post
    Probably not the same kind of ASUS bloatware in a G751 as in my G752, but I use the ROG Gaming Center app which allows you to disable the touchpad. This works and has continued to work for me.
    There isn't ANY bloatware on my G751 as I wiped the Windows 10 drive that it came with and did a fresh installation of Windows 7. I installed all of the drivers and programs myself. Perhaps I will give the ROG Gaming Center app a try. Can I download it from the ASUS website?

    Thanks.

  9. #9
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    176

    download this one..thats actually the newest one:
    https://dlcdnets.asus.com/pub/ASUS/G...0_64_V2510.zip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •