Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array pinhunter249 PC Specs
    pinhunter249 PC Specs
    MotherboardASUS TUF X299 Mark I
    ProcessorIntel Core i7-7800X
    Memory (part number)Corsair CMK32GX4M4A2666C16
    Graphics Card #1Gainward GTX1080 Phoenix GLH
    MonitorIiyama G-Master Red Eagle GB2488HSU-B3
    Storage #1Corsair Force MP500 240GB
    Storage #22x Crucial MX300 1TB
    CPU CoolerBe Quiet! Dark Rock Pro 3
    CaseCorsair Carbide Air 540 w/ ML fans
    Power SupplyCorsair HX1200i
    Keyboard Razer Ornata Chroma
    Mouse Razer Mamba Chroma TE
    Headset Razer Electra v2
    Mouse Pad Razer Goliathus
    Headset/Speakers Logitech 2.1
    OS Windows 10 Pro 64bit
    Network RouterNetGear GS108GE
    pinhunter249's Avatar
    Join Date
    Dec 2017
    Reputation
    10
    Posts
    1

    Rampage III Extreme AI Suite won't even install

    Hi guys,
    I recently put together a computer for my girlfriend containing a Rampage III Extreme, i7-980X & 24GB RAM
    and of course, running Windows 10 Pro

    problem I have is that, no matter which version I try to install, I always either get a message saying "The model does not support this application"
    or the install won't even start

    does anyone out there know of a solution?

    on my pc, I have the latest version running and I really like it

    thanks in advance
    Johan
    still waiting for The Saboteur 2...

  2. #2
    ROG Enthusiast Array idahosurge PC Specs
    idahosurge PC Specs
    MotherboardRampage VI Extreme
    Processor7820X @ 46 GHz / 3200 MHz
    Memory (part number)G.Skill F4-3600C15D-16GTZ (2 Kits 32 GB)
    Graphics Card #1Zotac Amp Extreme GTX 1080 Ti
    MonitorAlienware AW3418DW 34" GSync
    Storage #1OS - Samsung 850 Pro 513 GB
    Storage #2Backup - Samsung 850 Pro 1 TB
    CPU CoolerThermalright Archon IB-E x2
    CaseCooler Master HAF X
    Power SupplyCorsair AX860i
    Keyboard Corsair K95 RGB Platinum
    Mouse Logitech G703 Lightspeed
    OS Windows 10 Pro - 1709
    idahosurge's Avatar
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    46

    The board is 9 years old so maybe the latest versions do not support it.

    Have you tried going to the Asus support site, finding the R3E and downloading whatever version of AIS3 is available for the board?
    https://www.asus.com/us/supportonly/...Desk_Download/

    The link has v1.06.14 and you might have to press see all downloads to get it to show up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •