Results 1 to 7 of 7
  1. #1
    ROG Junior Member Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    4

    Intel ME update 12.0.22.1310 - error: Please check MEI Driver is installed

    Good morning,

    I am experiencing difficulties updating my Asus Maximus XI Extreme using the Intel ME link provided in the download page:
    https://www.asus.com/Motherboards/RO...HelpDesk_BIOS/

    This update program should bring ME to version 12.0.22.1310

    I have already updated the Bios to Version 0805

    When running the ME update program as admin, I am receiving this error message:
    Warning!!!
    Please check MEI Driver is installed.

    Click image for larger version. 

Name:	2019-03-13 ME update error message.jpg 
Views:	0 
Size:	8.9 KB 
ID:	79455

    I confirm indeed the ME is not updated: the system is running version 12.0.6.1120

    Could you please help me find a way forward?

    Cheers

    Full config details:
    Processor: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz
    Motherboard: Asus ROG MAXIMUS XI EXTREME / Bios version 0805 (latest at time of writing post)
    Memory: Corsair DDR4 2x8GB (SKU: CMD16GX4M2E4000C19)
    Graphic card: NVIDIA GeForce RTX 2080 / driver version 419.35 (latest at time of writing post)
    OS: Windows 10 Pro 64bits / version 1809 (latest at time of writing post)
    Last edited by Eguun; 03-13-2019 at 02:36 PM. Reason: added full config details

  2. #2
    ROG Junior Member Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    4

    I managed to manually update the ME firmware by doing the following:
    - opened elevated command line
    - navigate to MEUpdateTool_12.0.22.1310_T\FW folder
    - typed command: FWUpdLcl64.exe -F ME.bin
    - reboot

    System is now at 12.0.22.1310

    After update, the ASUS GUI for ME update still doesn't work (same error popup as before).

    Now looking into the text of the ASUS support download page I wonder exactly what they meant with this:
    *We suggest you update ME Driver to the latest Version 12.0.22.1310 simultaneously.

    So it seems there are 2 updates to perform: one for the firmware, and another one for the driver?


    Windows device manager indicates my driver version at: 1904.12.0.1208
    Click image for larger version. 

Name:	2019-03-13 ME driver version.jpg 
Views:	0 
Size:	60.4 KB 
ID:	79460

    Is there some drivers I should be updating too?
    Could you please share what's your driver version if you made this ME update properly (ie: using the ASUS GUI update program)?

    Thanks
    Last edited by Eguun; 03-13-2019 at 03:34 PM.

  3. #3
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2017
    Reputation
    12
    Posts
    271

    The driver version on your motherboard page is 1828.12.0.1152, though it might register as 1904.12.0.1208 on device manager.
    I don't understand ASUS statement also, as usually ME FW updates come as part of the BIOS bundle (well, at least up until now).

    Not sure why you are trying to re-run the GUI updater if you have already done so manually.
    You can check if your FW update was done in UEFI welcome screen, as ME version will be there, you just need to remember what it was before

    Although you have stated:

    System is now at 12.0.22.1310

    So, i guess you have somehow checked that already.
    Last edited by katlani; 03-13-2019 at 03:43 PM.

  4. #4
    ROG Junior Member Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    4

    Quote Originally Posted by katlani View Post
    The driver version on your motherboard page is 1828.12.0.1152, though it might register as 1904.12.0.1208 on device manager.
    I don't understand ASUS statement also, as usually ME FW updates come as part of the BIOS bundle (well, at least up until now).

    Not sure why you are trying to re-run the GUI updater if you have already done so manually.
    You can check if your FW update was done in UEFI welcome screen, as ME version will be there, you just need to remember what it was before

    Although you have stated:

    System is now at 12.0.22.1310

    So, i guess you have somehow checked that already.
    Thank you for your response.

    Why I tried to run the program again once FW was manually updated?
    Well I'm puzzled as to why I couldn't plainly update via the program provided by ASUS in the first place.
    So I figured maybe having the ME brought to latest version would have solved the issue raised by the error popup ... but it doesn't.

    I checked the ME FW version with the command line, using the update tool:
    FWUpdLcl64.exe -FWVER

    Actually, device manager showed that driver version you mention, starting with 18, but when clicking on the "update driver" button, it searched online and found updated drivers and brought the number up.
    No perceptible difference whatsoever

    Do you know why this error popup was raised in the first place?

    Thanks

  5. #5
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2017
    Reputation
    12
    Posts
    271

    Quote Originally Posted by Eguun View Post
    Thank you for your response.

    Why I tried to run the program again once FW was manually updated?
    Well I'm puzzled as to why I couldn't plainly update via the program provided by ASUS in the first place.
    So I figured maybe having the ME brought to latest version would have solved the issue raised by the error popup ... but it doesn't.

    I checked the ME FW version with the command line, using the update tool:
    FWUpdLcl64.exe -FWVER

    Actually, device manager showed that driver version you mention, starting with 18, but when clicking on the "update driver" button, it searched online and found updated drivers and brought the number up.
    No perceptible difference whatsoever

    Do you know why this error popup was raised in the first place?

    Thanks
    No clue for why its erroring out, perhaps yet another fubar installation from ASUS. Again, I would expect an ME FW update to come bundled within a BIOS version as it usually does.

    As for the driver, I wouldn't recommend updating the driver from Windows Update (that's what the update button does, goes to Windows Update Catalog) as driver updates better come from the vendor itself (ASUS) due to customizations, signoffs, and testing.

    The only driver I update regulary and dont wait for the ASUS one is NVIDIA driver, due to massive latency in release.

  6. #6
    ROG Junior Member Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    4

    Many thanks Katlani, your input helped a lot!

    I went to the download page of ASUS to download the Chipset component of Version 1828.12.0.1152 (which includes, in its description, the Intel Management Engine Interface).
    I installed it, which -I suspect- leveled my drivers to the plane ASUS expected.

    From there, I was able to flawlessly run the ASUS ME FW program: there was no longer the error popup.
    Yes, obviously my system's firmware was already updated, but I find it important to be capable of updating using the standard programs released by the manufacturer.
    So now I'm back on the rails.

    As conclusion, it seems this error message simply originated because in the first place, my Intel Management Engine components where updated via Windows Update and using instead ASUS elements enabled ASUS software to run: I never installed drivers from the ASUS support page, as all elements were recognized straight from Windows after install.

    Many thanks, this is resolved.
    Maybe it will help someone else facing this issue

  7. #7
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2017
    Reputation
    12
    Posts
    271

    NP.

    I just tried this myself on my PRIME Z370-A (different ME version update is available) by using the GUI.
    After it updated, i tried to run it again even, thinking it would wisely tell me its already updated, but it just re-updated again.

    Anyway, checked the version in UEFI welcome screen and was indeed updated.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •