Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    2

    Lightbulb G752VS GPU appears to be dead

    Hello folks, new to the forums, nice to be here.

    So, I'd left a game open to go eat, and on my return I noticed that the computer appeared to have gone to sleep. Long story short, as I've already made progress on partially understanding the issue on a BSOD forum, what I thought was the SSD being corrupted preventing me from booting, repairing, even launching in Safe Mode, is likely GPU related.

    I figured this out after reinstalling windows via USB and, upon attempting to install the GPU's driver, no matter where I sourced it from (Asus, Nvidia, Windows Update), as soon as the driver has installed the screen would blacken and I would be granted one chance to look around my desktop before a restart, whereupon we'd be sent back to square-one, the original issue.

    So, what could be wrong here? Anything I can really try to determine whether or not my baby is dead or not? I'm competent enough to open her up if necessary.

    Thanks folks

    GTX 1070, 8GB
    Last edited by Asusisgarb; 03-20-2019 at 12:08 AM.

  2. #2
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    2

    If anyone has any even semi relevant past experience they could share, I'd appreciate any and all direction y'all could give me!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •