Results 1 to 6 of 6

Hybrid View

  1. #1
    ROG Member Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    Strix Z390-E Wifi issues after BIOS update

    Hi,

    I recently updated to the newest 805 bios for my Strix Z390-E. Everything works fine except for the WIFI. It keeps disconnecting randomly. I
    ll be playing Apex and the wifi would disconnect and I can't find it forcing me to disconnect and reconnect. My other devices are all working fine. I can't seem to find any other posts about this. Wondering if anyone else has the same problems.

  2. #2
    ROG Guru: White Belt Array Enderwiggin03 PC Specs
    Enderwiggin03 PC Specs
    MotherboardROG STRIX Z390-E Gaming
    ProcessorIntel Core i9 9900k @ 5.1Ghz on all 8 cores 1.355v
    Memory (part number)F4-4266C19D-16GTZR @ 4000Mhz CL16-17-17-35 1.45v
    Graphics Card #1EVGA RTX 2070 XC Ultra
    Sound CardCreative Sound Blaster X AE-5
    MonitorASUS VG248QE
    Storage #1Samsung 970 Evo 500GB m.2
    Storage #2Samsung 860 Evo 1TB SATA
    CPU CoolerEVGA CLC280 with 4x NF-A14 iPPC-3000 PWM (push/pull)fans
    CaseFractal Design R6
    Power SupplyEVGA G3 1000w
    Keyboard Logitech G513 Carbon
    Mouse Logitech G703
    Mouse Pad Logitech Poweplay
    OS Windows 10 Home x64

    Join Date
    Nov 2018
    Reputation
    10
    Posts
    111

    Quote Originally Posted by Duckysaysquack View Post
    Hi,

    I recently updated to the newest 805 bios for my Strix Z390-E. Everything works fine except for the WIFI. It keeps disconnecting randomly. I
    ll be playing Apex and the wifi would disconnect and I can't find it forcing me to disconnect and reconnect. My other devices are all working fine. I can't seem to find any other posts about this. Wondering if anyone else has the same problems.
    Try an older bios and see if the issue persists.

  3. #3
    ROG Member Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    Quote Originally Posted by Enderwiggin03 View Post
    Try an older bios and see if the issue persists.
    So I went back to BIOS 602 and I got two random disconnects too. I'm thinking now it's a driver thing.

  4. #4
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    17
    Posts
    1,572

    Quote Originally Posted by Duckysaysquack View Post
    Hi,

    I recently updated to the newest 805 bios for my Strix Z390-E. Everything works fine except for the WIFI. It keeps disconnecting randomly. I
    ll be playing Apex and the wifi would disconnect and I can't find it forcing me to disconnect and reconnect. My other devices are all working fine. I can't seem to find any other posts about this. Wondering if anyone else has the same problems.
    CHeck on event viewer if DNS issues and let me know. I have the same issues, and I am blaming my ISP. We are using google DNS. but happens on other if i use other DNS.

    By any chance did you install the Version 12.0.22.1310 MEUpdateTool.?? I am just asking Aside other issues like audio features crashing etc?
    Learn, Play Enjoy!

  5. #5
    ROG Member Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    Quote Originally Posted by Itzycharles View Post
    CHeck on event viewer if DNS issues and let me know. I have the same issues, and I am blaming my ISP. We are using google DNS. but happens on other if i use other DNS.

    By any chance did you install the Version 12.0.22.1310 MEUpdateTool.?? I am just asking Aside other issues like audio features crashing etc?
    I did not install any other stuff besides BIOS, I did not install MEUPDATE TOOL. How do I check Event viewer? I'm not familiar with that.

  6. #6
    ROG Enthusiast Array AliAPCMR PC Specs
    AliAPCMR PC Specs
    MotherboardZ390 E
    Processori5 9600k
    Memory (part number)Corsair RGB Vengeance (Corsair CMR16GX4M2A2666C16)
    Graphics Card #1GTX 1070 EVGA FTW
    Sound CardAsus SupremeFX
    MonitorSamsung 1080p 40inch 3D Tv
    Storage #1Samsung Evo 500gb SSD
    Storage #23TB & 2TB &500GB HDD
    CPU CoolerNoctua U12S
    CaseNZXT Noctis 450
    Power Supply850 wats EVGA SUPERNOVA
    Keyboard Corsair Raptor K30
    Mouse Logitec M305
    Headset Creative Sound Blasters Rage V2 Wireless (RGB)
    OS Windows 10 (Latest Update)
    Accessory #1 NZXT GRID V2
    Accessory #2 NZXT HUE PLUS
    AliAPCMR's Avatar
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    44

    Can you guys confirm if your pc does a double boot when your pc is unplugged and the replugged back into the mains?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •