Results 1 to 3 of 3
  1. #1
    ROG Guru: Yellow Belt Array
    Join Date
    Feb 2012
    Reputation
    19
    Posts
    128

    Angry Maximum IV Extreme-Z - PCIE Bus Speed in Windows 10

    Hi Guys,
    Just upgraded to 10 pro from 7 ultimate.

    Running triple AMD 7970's all underwater.

    Asus dont offer any chipset drivers for Win 10.
    Is that normal?

    Ive got it all up and running cleanly, no problems, but I have no crossfire options in the AMD software.
    Ive unplugged one card to try and help diagnosis as triple cards can be hard work, wheere as 2 are normally easy.
    I have now noticed one card is at 16x and the other 2x on the PCIE bus.

    The software still wont offer me crossfire support.
    I have a feeling this is chipset driver related... But there are none to change!

    can anyone help at all?

    Asus Maximus IV Extreme Z
    i7 3770K @ 4.4ghz
    AMD 7970 HD x3 in TriFire @ 1200/1800.
    2x 240GHZ OCZ Vertex 3 SSD & 1x 512Gb Vertex 4
    16GB 2133mhz Patriot DDR3
    Ennermax Max Revo 1500w PSU
    Huge water loop with an internal EK 340mm & external Supernova 1260mm
    Windows 7 64 bit.

    Aquaero Fan control & monitoring

  2. #2
    ROG Guru: Yellow Belt Array SaLSouL PC Specs
    SaLSouL PC Specs
    MotherboardCrosshair VI Extreme
    ProcessorRyzen 7 2700x
    Memory (part number)trident RGB CL16 3200mhz 32GB
    Graphics Card #1MSI Gaming 6GB GTX 980Ti
    Graphics Card #2MSI Gaming 6GB GTX 980Ti
    Sound CardAstro A50 Wireless
    MonitorPhillips BDM4037U 40" 4k UHD Monitor
    Storage #1samsung 850 pro raid 0
    Storage #2WD Black 1tb Raid 0
    CPU CoolerCorsair H115i
    CaseCoolermaster Cosmos 2
    Power SupplyCorsair ax 1200i
    Keyboard Corsair K95 Platinum
    Mouse Corsair Scimitar RGB Pro
    Headset Astro A50 Gaming Wireless
    Mouse Pad corsair massive
    OS Win 10 x64 pro
    Network RouterAsus AC-3200
    SaLSouL's Avatar
    Join Date
    Mar 2012
    Reputation
    13
    Posts
    214

    Quote Originally Posted by Stu @ MSD View Post
    Hi Guys,
    Just upgraded to 10 pro from 7 ultimate.

    Running triple AMD 7970's all underwater.

    Asus dont offer any chipset drivers for Win 10.
    Is that normal?

    Ive got it all up and running cleanly, no problems, but I have no crossfire options in the AMD software.
    Ive unplugged one card to try and help diagnosis as triple cards can be hard work, wheere as 2 are normally easy.
    I have now noticed one card is at 16x and the other 2x on the PCIE bus.

    The software still wont offer me crossfire support.
    I have a feeling this is chipset driver related... But there are none to change!

    can anyone help at all?

    ++ LucidHydra NF200 Chip was probably what allowed 3 way to work, lucid no longer exist and there is no driver for win 10, you could try installing the lucid software in Win 7 compatibility mode. but im not sure of whether you will be successful.

    Click image for larger version. 

Name:	34way.PNG 
Views:	0 
Size:	7.0 KB 
ID:	79676
    Click image for larger version. 

Name:	manual.PNG 
Views:	0 
Size:	39.3 KB 
ID:	79677
    Last edited by SaLSouL; 03-25-2019 at 06:31 PM.

  3. #3
    ROG Guru: Yellow Belt Array
    Join Date
    Feb 2012
    Reputation
    19
    Posts
    128

    Thanks, apologoies for the late reply, I thin you are right, i eventually gave up and upgraded the lot.

    Maximum X / 8700K and a 2080.
    That solved the problem... LOL

    Asus Maximus IV Extreme Z
    i7 3770K @ 4.4ghz
    AMD 7970 HD x3 in TriFire @ 1200/1800.
    2x 240GHZ OCZ Vertex 3 SSD & 1x 512Gb Vertex 4
    16GB 2133mhz Patriot DDR3
    Ennermax Max Revo 1500w PSU
    Huge water loop with an internal EK 340mm & external Supernova 1260mm
    Windows 7 64 bit.

    Aquaero Fan control & monitoring

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •