Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    1

    z390a Stuck on dram/ no display

    Hi! I just put together my first build and I get no display to my monitor. The qled on my motherboard is stuck on dram with a constant yellow light. I've tried different ram and tried all possible slot combinations but no dice. I've also checked all my connections and everything is in the correct place and secure. Everything else seems to run fine so I'm thinking it's possibly the motherboard or gpu but I honestly wouldn't know.

    My specs are:
    CPU: Intel - Core i7-8700K 3.7 GHz 6-Core Processor
    CPU Cooler: CoolerMaster Hyper 212 Evo CPU cooler
    Motherboard: Asus Prime z390-A
    Memory: Corsair - Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 Memory
    Storage: Samsung - 860 Evo 500 GB 2.5" Solid State Drive
    Video Card: MSI GeForce RTX 2070 8 GB
    Power Supply: EVGA - Corsair - TX-M Series TX550M
    Monitor: Asus - VG248QE 24.0" 1920x1080 144 Hz Monitor

  2. #2
    ROG Guru: White Belt Array Enderwiggin03 PC Specs
    Enderwiggin03 PC Specs
    MotherboardROG STRIX Z390-E Gaming
    ProcessorIntel Core i9 9900k
    Memory (part number)F4-3866C18Q-32GTZR
    Graphics Card #1EVGA RTX 2070 XC Ultra
    Sound CardCreative Sound Blaster X AE-5
    MonitorASUS VG248QE
    Storage #1Samsung 970 Evo 500GB m.2
    Storage #2Samsung 860 Evo 1TB SATA
    CPU CoolerEVGA CLC280 with 4x NF-A14 iPPC-3000 PWM (push/pull)fans
    CaseFractal Design R6
    Power SupplyEVGA G3 1000w
    Keyboard Logitech G513 Carbon
    Mouse Logitech G703
    Mouse Pad Logitech Poweplay
    OS Windows 10 Home x64

    Join Date
    Nov 2018
    Reputation
    10
    Posts
    105

    Try different CPU? Was this with stock clocked or on XMP?

  3. #3
    ROG Guru: White Belt Array Super Gnome PC Specs
    Super Gnome PC Specs
    MotherboardROG Rampage VI Extreme Omega
    ProcessorIntel® Core™ i9-9980XE CPU @ 3.00GHz
    Memory (part number)Corsair LPX Vengeance DDR4 DRAM 2666MHz 128 GB
    Graphics Card #1Asus 2080 ti Turbo
    Graphics Card #2Asus 2080 ti Turbo
    MonitorJAPANNEXT JN-VT500UHD 4K 50-inch LCD
    Storage #1Crucial MX500 1 TB
    Storage #2Samsung 970 Pro 1 TB
    CPU CoolerROG Ryujin 360
    CaseThermaltake View 71 TG
    Power SupplyCORSAIR AXi Series, AX1600i 1600 watt
    Accessory #1 Noctua 140mm 3000 RPM x 4
    Accessory #2 Gigabyte GC-A 2WAY NVLINK RGB (3-slot)

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    77

    Not sure if this helps, but that sounds familiar. Is everything new? Do you have any way to check everything, for example your monitor, with other systems/components? Have you double checked your manual for something you may have missed? Are you getting beeps from the motherboard speaker? Are the fans running? Are you sure your ram sticks are seated properly? Are they compatible? I have had problems when stuff was not seated properly... Good luck!

    Have you seen this video? https://www.youtube.com/watch?v=VoMCXhCIy08

  4. #4
    ROG Guru: Diamond Belt Array Zka17's Avatar
    Join Date
    Mar 2012
    Reputation
    183
    Posts
    8,343

    To exclude an issue with the graphics card, you could connect the monitor to the built-in VGA...

    But, if it hangs at the RAM, the above thing wouldn't do too much... Have you tried to reseat the CPU?*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •