Results 1 to 3 of 3
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    56

    asus rampage vi extreme do not starting

    Hello, today i buy brand new asus rampage vi extreme, with i7-7800x 2066 cpu.
    But after assemble everything, pc do not start at all. Mobo light up, but noting more. No souds if something not work. No coolers spin no psu cooler spin, not even dash on left side of io. Basically pc do not start. Please help.

  2. #2
    ROG Enthusiast Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    56

    Here some images.
    Btw i try with cpu installed, without cpu, same deal. Mobo just do not start at all.Click image for larger version. 

Name:	tmp-cam--1329138120.jpg 
Views:	0 
Size:	65.6 KB 
ID:	79798Click image for larger version. 

Name:	tmp-cam--547352114.jpg 
Views:	0 
Size:	77.2 KB 
ID:	79797

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    56

    Guy someone can help amd tell me how to change the battery on Rampage VI extreme ?
    I wanna reset the bios coz it gave me bios error A2.. i did try everything and noting work.
    i try to reach the battery but i did not find a way to access that part. its covered by plastick.
    The problem came when i just put my HDD and 2 m.2 disck's
    When i put HDD have me error code A9, when remove HDD gave me A2 code.
    And mobo does not post anymore.

    Please help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •