Results 1 to 1 of 1
  1. #1
    ROG Enthusiast Array uplink PC Specs
    uplink PC Specs
    MotherboardAsus ROG Crosshair VIII Formula
    ProcessorAMD Ryzen 9 5950X
    Memory (part number)2 x 8GB [2 modules pending] F4-3800C14D-16GTZN running at D.O.C.P. with FCLK @ 1900 MHz
    Graphics Card #1Asus ROG RTX 3090 Strix OC
    Sound CardOnBoard S/PDiF
    MonitorAsus ROG XG27UQ [used to have Asus ROG PG27UQ]
    Storage #1Corsair MP600 512GB
    Storage #2Corsair MP600 1TB
    CPU CoolerAsus ROG Ryujin 360
    CaseStreacom BC-1
    Power SupplyAsus ROG Thor 1200
    Keyboard Logitech MX Keys [used to have Asus ROG Claymore]
    Mouse Logitech MX Master 3 [used to have Asus ROG Spatha]
    Headset Sony WH-1000XM4 [used to have Asus ROG Centurion]
    Mouse Pad Benq B&H BenQ ZOWIE G-SR [used to have Asus ROG Balteus]
    Headset/Speakers Plantronics/Poly Voyager Legend [used to have Asus ROG Centurion]
    OS Windows 10 Pro x64 20H2
    Network Router3x Asus ZenWiFi AX XT8

    Join Date
    Nov 2014
    Reputation
    10
    Posts
    57

    Angry What's wrong with You Asus? Armoury II 3.0.22 - a total mess

    Hey there

    I've had Spatha like 2 years ago, and now I purchased her again. It's a great hw I tell You. And I also gotten Claymore, not so great, but ok.

    Guys...I mean Asus guys. What's wrong with You? On so many levels at the same time. I installed Your Asus Armoury II. It's a mess. General, unusuable mess. I don't even know where to begin.

    The thing freezes like hell, You finally made Ai Suite work after two decades, now it's Armoury's turn. It's in version 3.xx.xx. It's not beta, it's a version 3 for goodness sake. Nothing works inside.

    I cannot connect to the internet via update, I cannot set my mouse up, because whenever I switch a profile, the whole armoury freezes and most likely crashes. Why do You do this? It's not like You're having a 50 types of SW to take care of. Aura, Armoury AiSuite and that's that. The thing for GPU/VGA is a disaster, delete it from Your project folder.

    Come on, this is a terrible thing. It's a 240e keyboard and 180e mouse, not some piece of dung 15e mouse/keyboard set.

    Get Your things together, please.

    regards

    Bryan

    P.S.: Why's Your forums in some gibberish language? [solved it]

    //edit: after 5 reinstalls, revo uninstaller, manual registry cleaning, everything works just fine. Please create some uninstaller for Your software, not only Ai Suite. Thank You.
    Miniatura de Adjuntos Miniatura de Adjuntos dafuq.jpg  

    the-hell.jpg  

    spatha.jpg  

    really.jpg  

    Last edited by uplink; 04-06-2019 at 07:55 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •