Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    6

    Gaming Center exits upon running. (GL503GE-EN270T)

    Hi all,
    This issue has crop up again.The previous workaround i used was uninstalling and reinstalling the Gaming Center Software ,but that didn't seem to help.Any inputs?

  2. #2
    ROG Guru: White Belt Array tap002 PC Specs
    tap002 PC Specs
    Laptop (Model)ROG Strix GL703GE-IS74
    MotherboardASUSTeK COMPUTER INC. GL703GE
    Processori7-8750H CPU @ 2.20GHz
    Memory (part number)16GB DDR4 2666MHz DRAM
    Graphics Card #1GTX 1050i
    Storage #1MICRON 1100_MTFDDAV256TBN
    tap002's Avatar
    Join Date
    May 2018
    Reputation
    12
    Posts
    122

    Stop or disable the service: ROGGamingCenterService
    This will allow you to launch Gaming Center without crashing. It will not read temps with out service running. After opening gaming center start the service it should work normally.
    By deafult the "startup type" for ROGGamingCenterService is automatic. Set it to manual and when you start gaming center it doesn't close and the service should start. P.S. I run as standard user; the service will not start when set on manual for a standard user. I have to go to services and start the service if I want temp readings in my gaming center.
    Clearly this is just a work around, don't know what is actually broken. I assume it is a NVIDIA driver, one of windows updates or combination. I see this complaint only occasionally so I don't think it is happening to a large number of people?
    Last edited by tap002; 04-08-2019 at 04:58 AM.

  3. #3
    ROG Member Array jocok's Avatar
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    10

    Hi , not the version of the graphic card is bugged. (or the thermal paste or your laptop)
    The problem is the newest nVidia Graphic Card driver! Make sure you're set your nVidia Card to default.
    Step 1; nVidai control panel - Open the Nvidia Control Panel. You can do this by right-clicking on the desktop or you can find the option within the notification area of the Taskbar.
    Step 2; Select Manage 3D Settings under 3D Settings.
    Step 3; Now select the 'preferred graphics processor' in the drop down list (you can see what the automatic option is listed as global setting). If you want to use the dedicated graphics card, select High-performance Nvidia processor. - This is the Important to select Dedicated nVidia Graphic card to your setting!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •