Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    1

    Maximus VIII Impact New Build No Power - Athena 500W FlexATX PSU

    Hi All

    Just completed build and using the Flex ATX 500W Power Supply from Athena is not turning on. This power Supply works fine with another PC and the ASUS is powering fine with a normal ATX 500W PSU.

    I have turned off Surge Protect in BIOS but it still doesn't power on using the Athena PSU.

    Is there a setting in the BIOS I must change to get it to work?

    Cheers

    Dan

    Specs are
    ASUS Maximus VIII Impact
    Intel 4Ghz
    16Gb RAM
    500Gb Sammsung 850SSD
    Windows 10
    GTX1050Ti GPU
    Athena Power 500W Flex ATX PSU

  2. #2
    New ROGer Array AS185 PC Specs
    AS185 PC Specs
    Laptop (Model)Lenovo ideapad Y700-17ISK
    MotherboardZenith Extreme
    ProcessorAMD 1950X
    Memory (part number)Goodram IRX3000D464L16S/8G x 8
    Graphics Card #1Gigabyte Geforce GTX 1080Ti Turbo
    Graphics Card #2Gigabyte Geforce GTX 1080Ti Turbo
    Sound CardGeforce GTX 1080Ti ~ HDMI ~ Yamaha HTR-4068
    MonitorLG 43UK6500MLA
    Storage #1Crucial MX500 1TB x 4
    CPU CoolerThermaltake Water 3.0 Ultimate
    CaseCorsair Obsidian 900D
    Power SupplyCoolermaster Titanium 1200W
    Keyboard Razer Ornata Chroma
    Mouse Razer Mamba Tournament Edition
    Mouse Pad steelseries
    Headset/Speakers Yamaha NS-F51/NS-P51
    OS Windows 10 Home
    Accessory #1 Razer Wolverine Tournament Edition
    AS185's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    126

    Hey Dan,
    Using the other power supply, I assume with a 4Ghz processor, you have it overclocked already. Turn off the overclock and check if it boots. Maybe the Athena power supply is inefficient with engaged overclock?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •