Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    3

    Anyone has a backup of BIOS 300 for GX501VS?

    Hi, asus live update recently decided to update my BIOS from 300 to 309 without asking me. I have been having trouble with 309 whereas the fans start spinning at 2500rpm with no reasons out of the blue, stop for 10 seconds, start again for 10 seconds and all over again. Needless to say this is driving me insane. I have tried Speedfan to control them to no avail. The only way to fix this issue at the moment is to roll back at 300 but it is not available online anymore.

    If anyone still has a copy of BIOS version 300 I would be indebted! Thank you

  2. #2
    ROG Guru: White Belt Array raju2529 PC Specs
    raju2529 PC Specs
    Laptop (Model)R542UQ-DM153 ( X542UQ.305 )
    MotherboardAsus motherboard
    ProcessorIntel core i5 7200u @2.5Ghz
    Memory (part number)Adata 2400 Mhz 16GB
    Graphics Card #1intel Hd 620 graphics 1GB DDR3
    Graphics Card #2Nvidia GeForce 940MX 2GB GDDR5
    Graphics Card #3nil
    Graphics Card #4nil
    Sound CardRealtek HD Audio controller with codec 294
    MonitorLcd monitor
    Storage #1Samsung 850 Evo 250GB SSD M.2. 2280
    Storage #2Seagate 2TB 2.5inch. Toshiba 1TB 2.5 inch
    CPU CoolerBuilt-in
    Casefrom factory
    Power Supply65W
    Keyboard Built in keyboard
    Mouse Built in mouse
    Headset Philips HeadSet
    Mouse Pad nil
    Headset/Speakers Realtek with ice sound
    OS Windows 10 64bit 1809 build no 17763.503
    Network RouterBsnl Wi-Fi modem with router

    Join Date
    Feb 2018
    Reputation
    10
    Posts
    118

    you can download from official site

  3. #3
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    4

    Quote Originally Posted by bluesknight25 View Post
    Hi, asus live update recently decided to update my BIOS from 300 to 309 without asking me. I have been having trouble with 309 whereas the fans start spinning at 2500rpm with no reasons out of the blue, stop for 10 seconds, start again for 10 seconds and all over again. Needless to say this is driving me insane. I have tried Speedfan to control them to no avail. The only way to fix this issue at the moment is to roll back at 300 but it is not available online anymore.

    If anyone still has a copy of BIOS version 300 I would be indebted! Thank you
    Hello,
    As I read you face an issue with your bios driver which update automatically and after that your fan working in the worst way
    Actually, this is happening due to your option choose to automatically download any driver so first, you have to stop that service.
    Then you go to download centre of Asus wherein the download history you find your system old BIOS version 300
    If you don't find that driver there then you have to search it online there are many sites which provide drivers check there.
    Hope this will help you.
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •