Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    3

    Hero 2 GL504GM FPS UP & DOWN?

    Hey guys,
    Basically as the title says, my fps in games is going up and down. In CSGO for example, it ranges between 150 to 220 ( All settings on low).
    I cant seem to figure out the reason. I have all the windows + nvidia settings configured for performance, everything for power saving is off as well.
    My temperatures are also always low ( max like 75 for both GPU & CPU)
    I think in general, isnt an average of lets say 180 fps on CSGO for hero 2 is low on low settings?
    Any ideas? Help would be greatly appreciated.

    Specs of my GL504GM: 1060GB, 16GB Ram, i7 8750.

  2. #2
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    3

    I have same model as you GL504GM, I run CSGO at max settings 1080 resolution and get around 120-140 fps, running latest nvidia driver 425.31 with geforce experience, I also have installed MyAsus app from windows store because my laptop came with no OS so I had some trouble getting all the drivers for the laptop, the cd provided with the laptop didn't install all the drivers, have no ideia why.

    You can also try to use GPU-Z from TechPowerUp and look at the sensors while playing to get an ideia of what's causing the fps difference, maybe performance is being capped for some reason, hope this helps.

  3. #3
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Jaddddd View Post
    Hey guys,
    Basically as the title says, my fps in games is going up and down. In CSGO for example, it ranges between 150 to 220 ( All settings on low).
    I cant seem to figure out the reason. I have all the windows + nvidia settings configured for performance, everything for power saving is off as well.
    My temperatures are also always low ( max like 75 for both GPU & CPU)
    I think in general, isnt an average of lets say 180 fps on CSGO for hero 2 is low on low settings?
    Any ideas? Help would be greatly appreciated.

    Specs of my GL504GM: 1060GB, 16GB Ram, i7 8750.
    did you update the BIOS to version 307
    if no, then update the bios
    it fixed it for me

  4. #4
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    3

    anyone did find solution yet. I just got solutions for the problem.

  5. #5
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    70

    Quote Originally Posted by netkantaph View Post
    anyone did find solution yet. I just got solutions for the problem.
    what was your solution??

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •