Results 1 to 10 of 14

Threaded View

  1. #1
    ROG Junior Member Array Quasimiyao@YT PC Specs
    Quasimiyao@YT PC Specs
    MotherboardMAXIMUS XII HERO
    Memory (part number)HX426C15FBK4/32 (KHX2666C15D4/8G x4)
    Graphics Card #1RTX3070
    Sound CardFocusrite Solo 2nd Gen/onboard
    MonitorSamsung C32HG70 and an older Asus.
    Storage #1WD Black something nvme 1TB
    Storage #2Samsung nvme something 250GB
    CPU Coolerold EK Block
    Power SupplyCorsair RM650i
    Keyboard Corsair K95 something something
    Mouse Logitech G900
    Headset Logitech G935
    Mouse Pad All of them
    Headset/Speakers Custom build
    OS Win10Pro
    Network RouterAsus RT-86u
    Quasimiyao@YT's Avatar
    Join Date
    May 2017

    ROG Centurion 7.1, dead audio station after firmware upgrade?

    Hey, just a question regarding my Rog Centurion headset. I updated to latest firmware the other day, and everything worked fine for a couple days. After turning off my pc for maybe 12 hours (something I usually never do, they tend to stay on 24/7) the headset is no longer recognised by windows. In device manager it says
    Unknown USB device (Port reset failed)
    and under device status I have the following message:
    windows has stopped this device because it has reported problems (code 43) 
    A USB port reset request failed.
    Not unfamiliar messages, have encountered them a few times through the years, but none of the usual troubleshooting tricks have worked so far.

    When I plug in the headset, no matter if its through a hub or in any of the ports of the mainbord (ASUS ROG MAXIMUS VIII HERO ALPHA, BIOS 3703) I get no sign of life on the audio station. No lights turning on, not even a blink, but the lights on the headset itself lights up for a second then disappear as well.

    So in summary, after updating firmware on the audio station everything worked fine, also after a reboot, but turning the PC off for a few hours ended with the headset saying goodbye.

    So is this a case of RMA (closing in on 2 years since I bought them) or is there a way to reflash the firmware, either downgrade, flash the same or the modified one from the sticky in this forum, when the pc, and then also the firmware tool, will not recognise the headset as being connected?
    Or any other ideas if someone have encountered the same issue and managed to fix it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts