Results 1 to 8 of 8
  1. #1
    ROG Enthusiast Array
    Join Date
    Dec 2018

    Corsair problems persist on CH7WIFI 2203

    Yep, I'm running the latest iCUE software, yes I've tried powering off my computer and unplugging it, yes I've tried reinstalling the software. This has been a problem on all BIOS later than 1002.

    If it was going to be fixed it would have been fixed by now, I'm just posting this so other folks will know.

  2. #2
    ROG Member Array Tunza PC Specs
    Tunza PC Specs
    MotherboardCroshair 7 Hero WIFI
    ProcessorRyzen 7 2700X
    Memory (part number)F4-3200C14-8GTZR (4 dimms @ 3200mHzC14
    Graphics Card #1ROG STRIX Vega 64
    MonitorMSI Optix MPG27CQ
    Storage #11tb Samsung 960EVO
    Storage #21TB Samsung 850 EVO
    CPU CoolerCorsair H100i V2
    CaseFractal Design Meshify C
    Power SupplyCorsair RMi 1000
    Keyboard Corsair K68
    Mouse Corsair DarkCoreSE
    Mouse Pad Seriously?
    OS Windows 10
    Network RouterD-Link DIR-890L
    Tunza's Avatar
    Join Date
    Jul 2018

    I have been waiting a very long time just as you have. TBH you were lucky it worked in 1002. I have tried all the 1xxx BIOS and the BIOS 2304 but nothing. In fact, all anything above 1002 gave me worse performance and iCUE still did not work correctly. Is it periferals or fans/coolers/ram you are trying to use? As long as I DISABLE iCUE on startup, don't run any monitoring tools (check background apps) and manually open iCue everything is detected. Unfortunatley you have to close it once you are done so no profiles continue to run. It is good for setting your fans though and then shut down. PAIN IN THE BUM THOUGH.

    I feel your pain man. If I had known my Corsair gear was gonna be this bad I probably woulda gone for MSI's 'trophy' X470 instead. who knows though. Asus blame AMD, AMD blame Asus, Corsar Blame Asus, etc etc.

    Good luck with it all. youll need it

    Tunza Down Unda :P

  3. #3
    ROG Member Array Needsnurfing PC Specs
    Needsnurfing PC Specs
    MotherboardAsus ROG Crosshair VII Hero
    ProcessorAMD Ryzen 7 2700X Eight-Core Processor
    Memory (part number)F4-3200C14-8GTZR 2x8GB
    Graphics Card #1Asus ROG Strix RXVega56
    Sound CardSteinberg UR12 Audio Interface
    MonitorLG 29" Ultrawide 2560x1080
    Storage #1Samsung SSD 960 EVO 250GB
    Storage #2Samsung SSD 850 EVO 1TB
    CPU CoolerCorsair H110i
    CaseCorsair Crystal 570x
    Power SupplyCorsair HX750i platinum
    Keyboard Corsair K70 MK2 low profile RGB
    Mouse Logitech G502 Proteus core
    Headset Audio-Technica ATH-A990Z Art Monitors
    Mouse Pad nooo!
    Headset/Speakers Edifier R2000DB
    OS Windows 10 64bit 1809.
    Network RouterASUS DSL-AC68U
    Accessory #1 Samson GO mic connect
    Accessory #2 Schiit audio modi(multibit)/magni stack
    Accessory #3 Track IR
    Needsnurfing's Avatar
    Join Date
    Dec 2018

    same boat.

    Same issue except non wifi CH7. Last working bios for me was 0804. I rolled back two days ago to 0804 to diagnose ram issues and sure enough first boot into windows all the corsair devices picked up.

    Sorted my ram problem and flashed back to 2203 and yep "device descriptor request failed"

    regardless of whose fault it ends up being ASUS should at the very least be working with Corsair to get the issues resolved whether that comes in the form of a bios update or icue update...

  4. #4
    ROG Guru: Yellow Belt Array Baio73 PC Specs
    Baio73 PC Specs
    MotherboardAsus ROG Crosshair VIII Formula BIOS 3402
    ProcessorAMD Ryzen 3900XT
    Memory (part number)2x8 Corsair 4000C19D
    Graphics Card #1Sapphire RX 5700XT
    MonitorLG 34GK950F
    Storage #1Samsung 980PRO 512Gb NVMe
    Storage #2WD Black SN850 2Tb NVMe
    CPU CoolerCorsair H150i Elite Capellix
    CaseLian Li 011D XL
    Power SupplyCorsair AX860i
    Keyboard Logitech G513
    Mouse Logitech G903 + Powerplay
    Headset G933 Artemis Spectrum
    Mouse Pad Corsair MM 700 RGB
    Headset/Speakers Logitech G560
    OS Windows 10 64bit
    Network RouterLynksys EA6500
    Accessory #1 Corsair Commander Pro
    Accessory #2 10xCorsair QL120 RGB fan

    Join Date
    Jul 2014

    New iCue version on the road… 3.16.56.
    Hope this may help.

    CASE Lian Li 011D XL CPU AMD Ryzen 3900XT COOLER Corsair H150i Elite Capellix MOBO Asus ROG Crosshair VIII Formula RAM 2x8 Corsair 4000C19D PSU Corsair AX860i VGA Sapphire RX 5700 XT DISPLAY LG 34GK950GF AUDIO Logitech G560 SDD Samsung 970PRO NVVe 512Gb - WD Black SN850 2Tb NVMe NPUT Logitech G903 + Powerplay + Corsair MM700 RGB - G513

  5. #5
    ROG Member Array bkgolden PC Specs
    bkgolden PC Specs
    MotherboardAsus - ROG Crosshair VII Hero WiFi
    ProcessorAMD - Ryzen 7 2700X
    Memory (part number)Corsair - Vengeance RGB Pro CMW16GX4M2C3200C16
    Graphics Card #1nVidia RTX 2080 FE
    MonitorAsus Rog Swift PG279q
    Storage #1Crucial MX500 1TB
    Storage #2SanDist Ultra II 960GB
    CPU CoolerCorsair 115i Pro
    CaseFractal Design Meshify C
    Power SupplyCorsair RMx 650
    Keyboard Corsair K70
    Mouse Corsair Dark Core RGB
    OS Windows 10 Home
    Accessory #1 Corsair LL 140 RGB Kit
    Accessory #2 Corsair Void Pro RGB

    Join Date
    Aug 2018

    Sorry to hear that you guys are still having issues. I was one of the first people to report issues with Asus BIOS and iCUE, but all my issues have long since been resolved after one of the iCUE updates. I'm running 2304 and no complaints. Good luck to you who are still having problems.

  6. #6
    ROG Member Array
    Join Date
    Dec 2018

    Yep latest BIOS latest Icue 3.16, still not detected

  7. #7
    ROG Member Array
    Join Date
    Dec 2018

    I've made a thread asking if the same issue will happen on the CH8. I am already looking at a platform upgrade for PCIE 4.0, so if CH8 has the same issue I'll just go MSI.

  8. #8
    ROG Enthusiast Array
    Join Date
    Nov 2018

    Try bumping up the SoC voltage using (+) offset. That's how I got mine to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts