Results 1 to 4 of 4

Threaded View

  1. #1
    ROG Junior Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    3

    GL702VS power button not working

    We have a GL702VS, that was working perfectly fine until a couple of days ago, when it stopped to turn on, when pressing the power button. I tried all the related solutions I could find online, but none of them worked. At the end I figured it out, that if I disconnect the battery and the CMOS battery (that we also tried to replace, made no difference) and wait about half an hour and connect everything, the power button will start working again. The only problem is, that it will stop working, when we completely shut down the machine.

    I tried playing with the fast shutdown option in Windows 10, no change. Tried updating BIOS (307), going back to default settings, nothing helped. Now the only way to turn on the machine is to disconnect everything, wait a few minutes and connect the charger and then it will start up automatically. If I wait more with everything disconnected I might be able to start it up with the power button, but the next time I will definitely have to disconnect everything again. After starting up and going to sleep I can wake up the machine by pressing space, the power button does nothing. I wanted to check the continuity of the circuit, but there is no separate control board and I don't know where it can be checked on this model.

    The charger works fine. When it's plugged in, the power led lights up and I can also see on the battery, that it is indeed charging.

    Otherwise, once it is started, everything works perfectly fine.

    Does anyone have any ideas what could be the problem? Any help will be much appreciated.
    Last edited by Forcecaster; 05-02-2019 at 09:45 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •