Results 1 to 5 of 5

Threaded View

  1. #1
    ROG Member Array Max Settings PC Specs
    Max Settings PC Specs
    MotherboardMaximus IX Hero
    ProcessorIntel Core i7-7700K
    Memory (part number)Corsair Dominator Platinum 32GB CMD32GX4M4A2400C14
    Graphics Card #1ASUS ROG Strix GeForce RTX 2070 Overclocked 8G
    MonitorASUS VG248
    Storage #1Corsair MP500 nvme ssd 240GB
    Storage #2WD Black 4TB HDD
    CPU CoolerCorsair h115i 280mm AIO
    CaseFractal Design Define R5
    Power SupplyCorsair AX1200i
    Keyboard ASUS ROG Strix Flare
    Mouse ASUS ROG Gladius II Origin
    OS Windows 10 Pro 64-bit

    Join Date
    Apr 2019
    Reputation
    10
    Posts
    7

    Gladius II Origin & Strix Flare Not Cooperating

    Friends, Romans, Computermen,

    I recently installed both the ROG Strix Flare Keyboard and the ROG Gladius II Origin Mouse on my computer running Windows 10 pro 64-bit. Both devices were attached to the computer at the same time, in the same "off state". Upon 1st boot, both devices were detected and installed by Windows (the installation sounds were audible). I checked in Device Manager to ensure they were picked up without error codes or problems. Everything looked perfectly fine. I had no devices showing any sorts of errors or problems.

    Next, I proceeded to install the Armoury software in addition to the Aura software as I had also just reformatted and performed a clean install of Windows (regular maintenance - not addressing any sort of problem). After installing Armoury, the keyboard was detected properly and displayed and I could make changes, edit its profile, etc. It was fine, for the keyboard that is. The mouse wasn't detected by Armoury at all. It was still connected properly and was shown in Device Manager without issue and it worked fine.

    That was a couple of days ago. I'm still hoping my mouse will show up in Armoury one day. I don't know what the problem is. I'm seeking advice. Is there a specific order in which these things should be installed? Is there a problem with Armoury and the Gladius II Origin? Does the mouse not want to play with the Strix Flare keyboard? What is the issue? I went ahead and installed Aura as well. The mouse isn't picked up in it either.

    Versions I'm using,
    Armoury 3.00.26
    Aura 1.07.55
    mobo BIOS 1301

    Please advise how I should proceed. I'd really like for all this to work together as advertised with both Armoury and Aura features/controls.

    Thanks
    Last edited by Max Settings; 05-04-2019 at 01:54 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •