Results 1 to 1 of 1
  1. #1
    ROG Enthusiast Array AliAPCMR PC Specs
    AliAPCMR PC Specs
    MotherboardZ390 E
    Processori5 9600k
    Memory (part number)Corsair RGB Vengeance (Corsair CMR16GX4M2A2666C16)
    Graphics Card #1GTX 1070 EVGA FTW
    Sound CardAsus SupremeFX
    MonitorSamsung 1080p 40inch 3D Tv
    Storage #1Samsung Evo 500gb SSD
    Storage #23TB & 2TB &500GB HDD
    CPU CoolerNoctua U12S
    CaseNZXT Noctis 450
    Power Supply850 wats EVGA SUPERNOVA
    Keyboard Corsair Raptor K30
    Mouse Logitec M305
    Headset Creative Sound Blasters Rage V2 Wireless (RGB)
    OS Windows 10 (Latest Update)
    Accessory #1 NZXT GRID V2
    Accessory #2 NZXT HUE PLUS
    AliAPCMR's Avatar
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    49

    Asus Armoury Crate Issue

    Hey guys I am having a issue with a brand new build with a z390 H and a i5 9600k, when i installed the OS installed and I booted into windows i get a prompt to download Armoury Crate and when i download it and run it, it provides me with a few software updates which when i try to install they always get stuck on 55% i have re installed the OS several times and i have installed all windows updates and installed the latest bios version and its still the same. Also when I run Crate it only gives me two options Highlights and Tools, None of the other advertised options are avaiable on the drop menu this is a brand new build no idea what the issue is here. I have uploaded a image to.

    Thanks for your help
    Miniatura de Adjuntos Miniatura de Adjuntos Asus issue.jpg  


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •