Results 1 to 1 of 1

Threaded View

  1. #1
    New ROGer Array
    Join Date
    May 2019

    Strix x370-i not posting to bios

    I get lights and fans.
    I get the Q-LED for DRAM on solid orange

    I don't get any system warning speaker beeps
    I don't get anything on my monitor
    I don't get any of the operating lights on my graphics card

    Mobo Rog Strix X370-i
    cpu Ryzen 5 1600
    gpu R9 Fury X
    ram Corsair Vengeance 2x8gb 3000mhz
    ssd Samsumg 970 Evo Plus

    Now the long read;

    Second build, so still learning the ropes. I've contacted Asus support, but hoping someone here might have a helpful tip. I turned it on had lights one beep and action. I installed windows 10 then started loading programs and updating drivers. When installing Ai suite 3 only EZY update would install. One piece I read said update the bios. I've updated bios before on other asus motherboards. I used the ezy update and it seemed to go well. restarted..then nothing.. except lights and fans.

    I've tried cmos reset several times, with and without the battery. Left everything unplugged overnight and tried again... Tried both ram sticks, one at a time in each slot several times. I've disconnected everything....yes even took out the cpu and re-seated it. Tried different hard drives and usb's with bootable operating systems. Still have a blank screen. Thinking of buying a cheaper ram to see if different ram will reset the bios. I'm pretty much bricked here, so any help is appreciated. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts