Results 1 to 1 of 1
  1. #1
    ROG Junior Member Array
    Join Date
    Dec 2016

    Question MAXIMUS VIII HERO - No USB after windows update.

    Ive been running windows 10 for the last year or so, without any issues, however when ever I've tried updating to the latest May update it seems to drop all USB connections and im unable to login. I can easily recover by uninstalling the update through windows recovery, but everything ive tried simply doenst work.

    Ive gone through the Asus website and installed all USB and Chipset drivers but to no avail.

    Generic USB Hub Driver: 10.0.17134.441 - 08/11/2018
    AsMedia USB Root Hub: - 11/04/2016
    USB Root Hub 3.0: 10.0.17134.441 - 08/11/2018

    Bios: latest version.

    Can anyone offer any advice on what might be causing this?
    USB equipment works fine in bios and everything pre-post but after that everything is lost.
    Last edited by barteh; 05-14-2019 at 11:50 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts