Results 1 to 7 of 7

Hybrid View

  1. #1
    ROG Member Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    7

    Drivers and W10 1903

    Are the current drivers compatible with the W10 1903 update?
    I read that the Bluetooth and wireless drivers need to be updated. I use BT.
    I won't update unless I know everything works well.

    If there are new drivers needed please update them or give me a link to the new drivers.


    https://docs.microsoft.com/nl-nl/win...ndows-10-1903:

    Unable to discover or connect to Bluetooth devices
    Microsoft has identified compatibility issues with some driver versions for Bluetooth radios made by Realtek and Qualcomm. To safeguard your update experience, we have applied a compatibility hold on devices with affected driver versions for Realtek or Qualcomm Bluetooth radios from being offered Windows 10, version 1903 or Windows Server, version 1903 until the driver has been updated.

    Affected platforms:

    Client: Windows 10, version 1903
    Server: Windows Server, version 1903

    Workaround: Check with your device manufacturer (OEM) to see if an updated driver is available and install it.

    For Qualcomm drivers, you will need to install a driver version greater than 10.0.1.11.
    For Realtek drivers, you will need to install a driver version greater than 1.5.1011.0.

    Note Until an updated driver has been installed, we recommend you do not attempt to manually update using the Update now button or the Media Creation Tool.

    Next steps: Microsoft is working with Realtek and Qualcomm to release new drivers for all affected system via Windows Update.
    Current drivers are outdated

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2017
    Reputation
    12
    Posts
    314

    i think also audio drivers on some boards are not 1903 ready, according to some threads, hence ASUS should indeed push to certify, customize and post new drivers/sofware which are 1903 ready.

  3. #3
    ROG Guru: White Belt Array JuSiZ1 PC Specs
    JuSiZ1 PC Specs
    MotherboardRampage VI Extreme Omega
    Processori9-7920X
    Memory (part number)G.skill TridentZ 4x8Gb DDR4 3200MHz cl14
    Graphics Card #1nVIDIA RTX 2080Ti Fe
    Sound CardCreative soundblaster X7 Le
    MonitorPG27AQ
    Storage #1Samsung 970pro 512Gb, Samsung 950 Pro 512Gb
    Storage #2Inte850pro 1Tbl 750 1.2Tb, 2x850pro 512gb and
    CPU CoolerEK Supremacy evo x99
    CaseDiy case
    Power SupplyCorsair Ax860i
    Keyboard Logitech G19
    Mouse Logitech G900 chaos Spectrum
    Headset Beyerdynamic T90
    Mouse Pad ROG from china
    Headset/Speakers Logitech Z4 2.1 And Monitors speakers
    OS Win 10 Pro 64-bit
    Network RouterFritz Box 6490
    Accessory #1 H2O cooling with 3x360 rads, dual ddc pumps,EK blocks, Copper pipes etc.
    Accessory #2 BD-RE
    JuSiZ1's Avatar
    Join Date
    Nov 2014
    Reputation
    18
    Posts
    90

    i just fresh install 1903 and everything works fine but only windows sleep mode not work. Pc goes to sleep but allways when wake up it reboots. I tried every fix what i found from internet but it doesn't work. Does someone has same problem? Some driver or bios outdated?

  4. #4
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    17
    Posts
    1,575

    i made the clean install yesterday ith my code xi. the audio driver was the only driver that was not working. I install the one from UAD from the post and all is fine. Also the gputweak ver 2.0 put the card crazy so i roll back. aside that I still need to test the armory. but the rest is doing fine. I recommend asus to update the drivers fast so people can install the update. is the bottle neck. And no, we can not put users on drivers only.
    Learn, Play Enjoy!

  5. #5
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    10

    The bluetooth driver need to be updated on my z270e strix to install 1903 I think.
    My motherboard page is still offering driver from 2017 version 10.0.0.309

  6. #6
    ROG Guru: White Belt Array
    Join Date
    May 2014
    Reputation
    28
    Posts
    102

    I done a clean install on my strix x299 gaming i used all drivers from https://www.win-raid.com/forum.php chipset,mei,raid,lan all other driver from driverstation far as audio onboard i don't use i have a dedicated asus stx ii sound card i used nlite to make a self install with 1903 and it is perfect no driver issues at all and no other problems now for about 3 weeks now
    Asus Rampage VI Extreme / Intel I9-7940X / Corsair H115i Pro / CORSAIR Vengeance RGB Pro 32GB (4 x 8GB) 3000MHz / EVGA GeForce GTX 1080 Ti FTW3 ELITE GAMING BLACK Edition / 2x Samsung 970 Pro NMVe 1GB / 4x Samsung 850 PRO - 2TB / Asus ROG Swift PG348Q / Corsair AX 1500i / Thermaltake View 71 RGB PC Case /Win 10 PRO x64

  7. #7
    ROG Member Array
    Join Date
    Dec 2017
    Reputation
    17
    Posts
    16

    What are the minimum drivers u need for R6E at W10 1903? Download page gets confusing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •