Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    3

    RTX 2080 broken?

    Hi.

    Over three months ago I have purchased my first nVidia card since RivaTNT2. I've purchased ASUS ROG STRIX GAMING RTX 2080 OC. After one hour of playing the 3D graphics started to show random artifacts (black triangles or flares depends on title) or just crash. I have tried many different version of drivers and I have tried the card on three different PCs. On every of them it is the same: artifacts or crashes. I have issued RMA twice, described the problem, attached sample video showing artifacts but every time ASUS service center returns the card as "working correctly". I don't know what to do. Can anyone help me who can I contact to to have my problem solved?

    I'm starting to regret I have purchased nVidia GPU and most important I'm starting to regret I have purchased another ASUS product (so far I had a lot of them and no problems with any of them).
    Last edited by denbi; 06-03-2019 at 02:48 PM. Reason: misspelling

  2. #2
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    3

    Here is the video from 3 different titles showing artifacts. Is it something that can be fixed by software (new drivers) or is it hardware problem?

    https://youtu.be/6gNZnRxRcCk

  3. #3
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    11
    Posts
    1,204

    RMA the GPU i have seeing these all ready. 1 time only. i have see the space invader, the random freeze (audio fine the computer is working but fps is 0 or black screen) and the one like yours. One of the cards that i check, a friend did change the psu. and was fine. After 1 week start happening. Rma the card. I all ready report these to my PR ASUS in my area
    Learn, Play Enjoy!

  4. #4
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    3

    OK. I have issued RMA for the third time. Let's see what ASUS service say this time. Cross the fingers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •