Results 1 to 6 of 6
  1. #1
    New ROGer Array denbi PC Specs
    denbi PC Specs
    MotherboardAsus PRIME X470-PRO
    ProcessorAMD Ryzen 7 2700X
    Graphics Card #1Radeon Rx 480
    Graphics Card #2RTX 2080 (broken)
    CPU CoolerNoctua NH-D15
    CaseFractal Design Define R5 White
    Power SupplyCorsair RM750X

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    5

    RTX 2080 broken?

    Hi.

    Over three months ago I have purchased my first nVidia card since RivaTNT2. I've purchased ASUS ROG STRIX GAMING RTX 2080 OC. After one hour of playing the 3D graphics started to show random artifacts (black triangles or flares depends on title) or just crash. I have tried many different version of drivers and I have tried the card on three different PCs. On every of them it is the same: artifacts or crashes. I have issued RMA twice, described the problem, attached sample video showing artifacts but every time ASUS service center returns the card as "working correctly". I don't know what to do. Can anyone help me who can I contact to to have my problem solved?

    I'm starting to regret I have purchased nVidia GPU and most important I'm starting to regret I have purchased another ASUS product (so far I had a lot of them and no problems with any of them).
    Last edited by denbi; 06-03-2019 at 02:48 PM. Reason: misspelling

  2. #2
    New ROGer Array denbi PC Specs
    denbi PC Specs
    MotherboardAsus PRIME X470-PRO
    ProcessorAMD Ryzen 7 2700X
    Graphics Card #1Radeon Rx 480
    Graphics Card #2RTX 2080 (broken)
    CPU CoolerNoctua NH-D15
    CaseFractal Design Define R5 White
    Power SupplyCorsair RM750X

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    5

    Here is the video from 3 different titles showing artifacts. Is it something that can be fixed by software (new drivers) or is it hardware problem?

    https://youtu.be/6gNZnRxRcCk

  3. #3
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    13
    Posts
    1,431

    RMA the GPU i have seeing these all ready. 1 time only. i have see the space invader, the random freeze (audio fine the computer is working but fps is 0 or black screen) and the one like yours. One of the cards that i check, a friend did change the psu. and was fine. After 1 week start happening. Rma the card. I all ready report these to my PR ASUS in my area
    Learn, Play Enjoy!

  4. #4
    New ROGer Array denbi PC Specs
    denbi PC Specs
    MotherboardAsus PRIME X470-PRO
    ProcessorAMD Ryzen 7 2700X
    Graphics Card #1Radeon Rx 480
    Graphics Card #2RTX 2080 (broken)
    CPU CoolerNoctua NH-D15
    CaseFractal Design Define R5 White
    Power SupplyCorsair RM750X

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    5

    OK. I have issued RMA for the third time. Let's see what ASUS service say this time. Cross the fingers!

  5. #5
    New ROGer Array denbi PC Specs
    denbi PC Specs
    MotherboardAsus PRIME X470-PRO
    ProcessorAMD Ryzen 7 2700X
    Graphics Card #1Radeon Rx 480
    Graphics Card #2RTX 2080 (broken)
    CPU CoolerNoctua NH-D15
    CaseFractal Design Define R5 White
    Power SupplyCorsair RM750X

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    5

    Bad news. It seems ASUS service center in Czech Republic (they handle RMAs from Poland) for the third time said, my card is working correctly. :-( That's ridiculous!!! I've tested it on 3 different PCs! What can I do? Can anyone help me, please?

  6. #6
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    13
    Posts
    1,431

    Quote Originally Posted by denbi View Post
    Bad news. It seems ASUS service center in Czech Republic (they handle RMAs from Poland) for the third time said, my card is working correctly. :-( That's ridiculous!!! I've tested it on 3 different PCs! What can I do? Can anyone help me, please?
    the test can be done liek these and make a video.

    1. load defaults on bios. last bios
    2. DDU and load the last driver.
    3. Load gputweak and create a fan profile curve that at 60C the fans ramp to 100%. move the power target and temp target to the max and save. make a profile from OC .
    4. download furtmark. and make stress.
    5. Play games.

    Scenarios 1. Space invaders 2. the screen freeze but there is sound. 3 Most of the time will work. In fact take me 2 weeks to check these anomaly other 2 cards was instantaneous. On furtmark artifact on the test is present. If you use the asus one, and select the max test ARTIFACT WILL BE PRESENT on the first 2 runs o thr 5. as soon the card get hot is present let me look for the pictures test and post a link so you can check. Is on Spanish but is clear test. If a RMA center CAN NOT see these, they are noobies. Sorry asus. These is present ON ALL RTX 2080ti that have issues, regardless the brand MODEL and series. if a card can not pass a furmark on the first runs using app presets or stock values, THE RMA has to pass. these apps are not recommended. But if you use the card and use games or worst application like octane maya video edition etc that is what we do here, RMA has to be approve.

    since the last 2 week i have being putting computers to renew the one on a tv station. all is asus , but the gpu are another brand. FROM 15 cards 3 came bad. All stress where done 8h basis. since when a render or video procecing is done even with dual 2080ti renders last 18h. for 3minutes tv spot. if the card fails on 2 days on these RMA. if the cards fails on first use, RMA is aprove. space invader RMA has to be approve.

    THEY has to use the card 1 test does not do crap.

    Let me prepare the link during the day and load the videos and pictures so you can check and tell them TO USE THE CARDS. they have to.
    Learn, Play Enjoy!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •