Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    12

    G75VW, Via Audio Deck in Windows 10?

    So I'm having a problem with my old G75VW and the sound drivers.
    I seem to be unable to install them properly.

    First off, the installers don't work at all, they run but they seem to actually install squat and the sound system still just uses the generic Windows drivers. I've tried as recent drivers as "v11_1100f", which are the latest I've been able to find.
    I can install the drivers themselves manually and the system does accept them and identifies the audio device as VIA HD Audio(Win 10), but that of course leaves me without the Audio Deck control software to properly configure it.

    Does anyone know of a solution to this little problem? Or is it one of those inevitable pains of ageing hardware that one just has to grin and bear?

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2012
    Reputation
    55
    Posts
    425

    VIA has no Windows 10 Audio devices. The latest that have been built require Windows 8.1/8.0. Look on their download page, select Microsoft Windows operating type, Windows 8/8.1 operating system, Audio driver type, and VIA Vinyl HD Audio Codecs. This will take you to another page where you can download the latest driver (10.1200A)

    http://download.viatech.com/en/suppo...versSelect.jsp

    You can also download a customized copy of this driver from ASUS:

    https://dlcdnets.asus.com/pub/ASUS/n...ER60110200.zip

    Good Luck
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •